Ask Your Question
0

Unable to connect to AMQP server

asked 2014-07-03 16:31:30 -0500

andi gravatar image

I used devstack in the all-in-one config. This is working well. I gave this box, which I'll call the "controller" box, the IP 192.168.40.4.

Now, I am trying to add a single extra compute node to the setup. So I created a new box with IP 192.168.40.5. I used a local.conf that has this

[[local|localrc]]

disable_all_services
enable_service neutron nova n-cpu qpid
...
RABBIT_PASSWORD=stackqueue
QPID_PASSWORD=stackqueue
...
HOST_IP=192.168.40.5
SERVICE_HOST=192.168.40.4

./stack.sh on the new compute node works fine. But when I go to the n-cpu screen, I see that n-cpu is having trouble connecting to the AMQP server running on the controller node. I see messages like this:

2014-07-03 17:19:35.684 ERROR oslo.messaging._drivers.impl_qpid [req-9af44cb5-4dab-4a79-92bc-bd50f9f11006 None None] Unable to connect to AMQP server on {'username': '', 'host': '192.168.40.4:5672', 'password': ''}: client: 0-10, server: 9-1. Sleeping 5 seconds

What is going wrong? How can I fix this?

It looks like rabbitmq is running and that I can reach it from both controller and the new compute node, since I can telnet into the controller at the rabbit port (see http://rubybunny.info/articles/troubl... .

from the controller:

[vagrant@vagrant-fedora20 devstack]$ telnet localhost 5672
Trying ::1...
Connected to localhost.
Escape character is '^]'.
asdlfjkasf
AMQP    Connection closed by foreign host.

and from the compute node:

[vagrant@vagrant-fedora20 devstack]$ telnet 192.168.40.4 5672
Trying 192.168.40.4...
Connected to 192.168.40.4.
Escape character is '^]'.
asdjflasdj
AMQP    Connection closed by foreign host.

So that seems to rule out firewall problems.

It seems suspicious that in the connection to the amqp server the username and password are empty strings. Could this be the problem? Where do I specify the amqp username and password to use for the n-cpu process?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-03 22:56:37 -0500

andi gravatar image

I was able to resolve the problem. I think the problem is that I did not include rabbit in my enabled services on the compute node. Concretely, I set this in my local.conf:

enable_service n-cpu rabbit neutron q-agt

and added

MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
Q_HOST=$SERVICE_HOST

and then rebuilt the compute node. After this, I'm able to connect to AMQP and the compute node shows up in the hypervisor-list.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-03 16:31:30 -0500

Seen: 1,674 times

Last updated: Jul 03 '14