Ask Your Question
1

Validating and Installing OS-KSEC2 admin extension

asked 2014-07-01 08:31:32 -0500

Hoots gravatar image

updated 2014-07-01 08:35:39 -0500

I would like to be able to call the api...

/v2.0/users/​{userId}​/OS-KSADM/credentials

which after looking at http://developer.openstack.org/api-ref-identity-v2.html seems to be part of the OS-KSEC2 admin extensions. If I make a call to it with my current icehouse installation I get the response...

<error xmlns="http://docs.openstack.org/identity/api/v2.0" message="The resource could not be found." code="404" title="Not Found"/>

I know the userId is valid as removing the '/OS-KSADM/credentials' returns the correct user information, so it suggests that OS-KSEC2 isn't installed. How do I go about verifying that and installing it?

edit retag flag offensive close merge delete

Comments

So noone knows how to install this then!!

Hoots ( 2014-07-28 04:29:18 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2014-10-10 13:56:53 -0500

annegentle gravatar image

updated 2014-10-10 14:07:00 -0500

It's basically an extension called with the OS-KSADM extension call.

See http://developer.openstack.org/api-re...

So I can't tell if you're calling it correctly, such as: /v2.0/users/​{userId}​/OS-KSADM/credentials/OS-KSEC2:ec2Credentials

If you are calling both OS-KSADM and OS-KSEC2:<properties> and have admin permissions and still get the 404, then check your keystone-paste.ini file to see if the v3 API is enabled rather than the v2.0 API.

http://docs.openstack.org/icehouse/co...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-07-01 08:31:32 -0500

Seen: 408 times

Last updated: Oct 10 '14