icehouse horizon instance console cannot be displayed

asked 2014-06-29 08:52:32 -0600

dragos gravatar image

updated 2014-06-29 09:07:05 -0600

I have installed icehouse following the guide from the openstack site. After I launched an instance I cannot access it via the console tab in the horizon interface. I tried it with IE, firefox and chrome.

Could you please tell me wha could be the cause ? ty

edit retag flag offensive close merge delete


what error message are you getting?

fifieldt gravatar imagefifieldt ( 2014-06-29 22:37:42 -0600 )edit

it depends on the browser on firefox is : This address is restricted.This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.

on chrome is : Something like "The web page at http://controller:6000/vnc_auto.html?... might be temporarily down or it may have moved permanently to a new web address."

error code: ERR_UNSAFE_PORT

In both browsers i followed instructions to permit port 6000

dragos gravatar imagedragos ( 2014-06-30 01:42:11 -0600 )edit

Maybe your openstack-nova-novncproxy service is stopped. Check "service openstack-nova-novncproxy status" and "openstack-service status" commands to be sure that everything is running.

Marcos F. Lobo gravatar imageMarcos F. Lobo ( 2014-06-30 01:55:23 -0600 )edit

for "service openstack-nova-novncproxy status" i get "openstack-nova-novncproxy: unrecognized service" for "openstack-service status" i get "openstack-service: command not found "

dragos gravatar imagedragos ( 2014-06-30 02:01:58 -0600 )edit

What should I do to get them going ?

dragos gravatar imagedragos ( 2014-06-30 02:15:14 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-06-30 12:50:31 -0600

rahulrajvn gravatar image


Please try changing the hostname to your IP in the nova configuration file for following entries .

On controller server

Public IP on contreller server. For me Hostname don't work and I had to give the IP.

openstack-config --set /etc/nova/nova.conf DEFAULT my_ip

openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_listen

openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_proxyclient_address

Configure Compute to provide remote console access to instances. Ip on compute Server

openstack-config --set /etc/nova/nova.conf DEFAULT my_ip

openstack-config --set /etc/nova/nova.conf DEFAULT vnc_enabled True

openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_listen

openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_proxyclient_address

edit flag offensive delete link more


the problem is when i do "service novnc restart" i get the error "novnc unrecognized service".

dragos gravatar imagedragos ( 2014-07-01 04:32:06 -0600 )edit

Check which all nova services has been installed using

ls /etc/init.d/ |grep openstack-nova

My output is

openstack-nova-api openstack-nova-cert openstack-nova-conductor openstack-nova-console openstack-nova-consoleauth openstack-nova-metadata-api openstack-nova-novncproxy openstack-nova-scheduler openstack-nova-spicehtml5proxy openstack-nova-xvpvncproxy

rahulrajvn gravatar imagerahulrajvn ( 2014-07-01 06:23:29 -0600 )edit

i get no output from this command

dragos gravatar imagedragos ( 2014-07-01 08:50:02 -0600 )edit

Anyone ever figure this out? I can't connect to console for my instances in icehouse either.

IPv6Freely gravatar imageIPv6Freely ( 2014-11-17 10:57:36 -0600 )edit

The service is in /etc/init/nova-novncproxy.conf and it can be called using 'service nova-novncproxy' and it is the 'apt-get install novnc' package.

admiles gravatar imageadmiles ( 2014-11-19 14:14:15 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-06-29 08:52:32 -0600

Seen: 1,879 times

Last updated: Jun 30 '14