Ask Your Question
0

Cannot change br-int and br-tun MTU to >1500

asked 2014-06-28 02:52:50 -0500

Marwan AKIKI gravatar image

updated 2014-06-28 03:00:08 -0500

we have a server setup where openstack components are KVM-VMs:

  1. icehouse-controller.

  2. icehouse-network.

  3. icehouse-cinder.

All these components are attached to a bridge br-main-vm over subinterface (vlan 112) --> em2.112 of the main giga-ethernet interface em2.

Thus, VM --> br-main-vm --> em2.112 --> em2.

 - All interfaces have mtu=9000 configured in the interfaces file.

 - Further each VM has its interface configures to mtu=9000.

 - Pinging and passing data can be performed with packet > 1500.

However, br-int and br-tun (GRE) MTUs cannot be configured. They have by default 1500. I tried the veth_mtu = 9000 in the [agent] section of ml2_conf.ini but in vain.

I do not want to reduce the guest VM MTU; thus, how to proceed.

Hint: I tried to change the MTU in: nano /sys/devices/virtual/net/br-tun/mtu and nano /sys/class/net/br-tun/mtu but it did not work, ovs rewrite them.

Regards Marwan

edit retag flag offensive close merge delete

Comments

Did you try changing this with ifconfig? It might be as "simple" as writing a script that runs after startup to ifconfig mtu=blah. I don't see this option set in ovs natively. I know that there are ways to do this because people are able to configure it.

mpetason gravatar imagempetason ( 2014-06-30 13:42:04 -0500 )edit

Hi, I am also facing similar issue, were you able to find out the solution ?

prat gravatar imageprat ( 2014-10-07 04:28:58 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-30 10:36:04 -0500

granadol gravatar image

You change guest MTU by configuring this in the /etc/neutron/dhcp_agent.ini: dnsmasq_config_file=/etc/neutron/dnsmasq-neutron.conf

Then create the dnsmasq-neutron.conf with this:

dhcp-option-force=26,1400

This forces an MTU of 1400

edit flag offensive delete link more

Comments

Sorry. Just read where you don;t want to reduce guest. Please disregard

granadol gravatar imagegranadol ( 2014-06-30 10:37:39 -0500 )edit

he same problem for me.

Instance running MTU 9000 I have set dhcp-option-force=26,9000 But still br-int and ovs qdhcp- interfaces is running mtu 1500.

JonasH gravatar imageJonasH ( 2014-09-18 00:27:51 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-06-28 02:52:50 -0500

Seen: 1,445 times

Last updated: Jun 30 '14