Ask Your Question
0

Icehouse: No Internet Access

asked 2014-06-27 17:48:34 -0500

Mark gravatar image

Trying to build a 3 node OpenStack environment, using Neutron, based on Ubuntu 14.04 and VMWare Fusion. I am following the OpenStack Doc for Icehouse and am currently on Chapter 2 Basic Environment Configuration. The nodes are all setup as per doc and can all ping each other as per the verify connectivity step at the end of that section.

However, none of them can access the internet either by ping'ing say 8.8.8.8 or http://www.google.com . The error on the ping 8.8.8.8 is "Host Unreachable". The same is true for the controller and compute1 nodes as well.

As I said, this is at the basic environment configuration step so no OpenStack services/packages are installed or configured yet.

Can anyone help?

Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-28 06:25:23 -0500

Mark gravatar image
Fixed.

I'm not sure this is working how the OpenStack manual intended at this time, but it works as per the verify step at the end of the basic networking setup between the VM's.

This is what I did:

1. Created a new custom network connection by :
a Accessing the Menu: VMWare Fusion->Preferences->Network and clicking the "+"
b. Set all the tick boxes ticked (Allow VM's to connect to external networks, connect host MAC to this network &  provide addresses on this network via DHCP - not sure DHCP was necessary, but  did it anyway)
c. Set subnet IP to 10.0.0.0
d. Set subnet mask to 255.255.255.0
e. Clicked "Apply"

2. Asigned this custom network interface to all nodes (network, controller, compute1) on the interface defined as eth0 (10.0.0.xx addresses) by:
a. Accessing the settings for each VM 
b. Under "Removable Devices" click "Network Adapater"
c. Set it to use vmnet3 adapter under custom section
b. Ensure "Enable Network Adapter" is set to "ON"  

3. Specifically for the Network Node VM created 2 more Network Adapters (total of 3) and set them to Private to my Mac by:
a. Accessing the settings for VM
b. Click "Add Device"
c. Select the newly added adapter "Network Adapter x" (where x is 2, 3 or whatever number your new adapter was assigned)  
d. Set it to use the "Private to my Mac" adapter under the custom section
e. Ensure "Enable Network Adapter" is set to "ON"
f. Do points b to e again to add another adapter for a total of 3 network adapters (first already there and configured in point 2)    

4. Specifically for the Compute1 Node VM create 1 more Network Adapters (total of 2) and set them to "Private to my Mac" by:
a. Accessing the settings for VM
b. Click "Add Device"
c. Select the newly added adapter "Network Adapter x" (where x is 2, 3 or whatever number your new adapter was assigned)  
d. Set it to use the "Private to my Mac" adapter under the custom section
e. Ensure "Enable Network Adapter" is set to "ON"

5. Steps 1 -3 should result in the first Network Adapter for each VM assigned to vmnet3 & the rest (2 on network and 1 on compute1) set to "Private to my Mac"

6. Edit /etc/network/interfaces file for the network vm as follows:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address 10.0.0.21
    netmask 255.255.255.0
    gateway 10.0.0.2
    dns-nameservers 10.0.0.2

auto eth1
iface eth1 inet static
    address 10.0.1.21
    netmask 255.255.255.0

auto eth2
iface eth2 inet manual
    up ip link set dev $IFACE up
    down ip link set dev $IFACE down

7. Edit /etc/network/interfaces file for the controller vm as follows:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address 10.0 ...
(more)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-27 17:48:34 -0500

Seen: 278 times

Last updated: Jun 28 '14