Ask Your Question
0

my stack keeps giving DHCP to my network

asked 2014-06-26 17:30:29 -0600

anonymous user

Anonymous

How do I keep my devstack setup from thinking it's a dhcp server? I am planning to assign IPs manually to instances from a pool of static IPs I have been assigned. However I am finding it's handing IPs to other machines on the subnet.

dnsmasq is excluding lo. Should I also get it to exclude eth0? if so, where? Or is there a better way to turn off this behavior?

edit retag flag offensive close merge delete

Comments

are u using neutron for creating your networking?

vasanth-rajasekaran gravatar imagevasanth-rajasekaran ( 2014-06-26 23:46:35 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-06-27 08:54:10 -0600

Banix gravatar image

If you are using Neutron, you can disable dhcp in devstack by adding the following in local.conf (or localrc):

disable_service q-dhcp

Please refer to http://devstack.org/stackrc.html and http://devstack.org/configuration.html for more information on how to configure your devstack installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-26 17:30:29 -0600

Seen: 66 times

Last updated: Jun 27 '14