Ask Your Question
3

ImportError: No module named rootwrap.cmd

asked 2014-06-26 09:18:10 -0500

Vinoth gravatar image

updated 2014-06-27 16:37:50 -0500

smaffulli gravatar image

I am installing Icehouse. I have configured till nova controller service. But when I start the nova-api service. It runs for few seconds and turn to stop status. Only error i'm getting is in /var/log/upstart/nova-api which says

TRACE nova ProcessExecutionError: Unexpected error while running command.
2014-06-26 14:03:41.285 10013 TRACE nova Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iptables-save -c
2014-06-26 14:03:41.285 10013 TRACE nova Exit code: 1
2014-06-26 14:03:41.285 10013 TRACE nova Stdout: ''
2014-06-26 14:03:41.285 10013 TRACE nova Stderr: 'Traceback (most recent call last):\n  File "/usr/bin/nova-rootwrap", line 6, in <module>\n    from oslo.rootwrap.cmd import main\nImportError: No module named rootwrap.cmd\n'

I also checked manually running comand

 nova-rootwrap /etc/nova/rootwrap.conf iptables-save -c

which shows

Traceback (most recent call last):
  File "/usr/bin/nova-rootwrap", line 6, in <module>
    from oslo.rootwrap.cmd import main
ImportError: No module named rootwrap.cmd

What's wrong?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-06-27 16:38:46 -0500

smaffulli gravatar image

You are missing a python package called rootwrap.

edit flag offensive delete link more

Comments

I get the exact same error messages as the questioner, and when I run sudo apt-get install python-oslo.rootwrap it tells me python-oslo.rootwrap is already the newest version. so there has to be another issue/solution. (Debian 7.7)

programster gravatar imageprogramster ( 2014-12-10 09:43:15 -0500 )edit
1

pip install oslo.rootwrap --upgrade resolved the issue.

programster gravatar imageprogramster ( 2014-12-10 09:46:45 -0500 )edit
0

answered 2014-06-30 04:49:51 -0500

koolhead17 gravatar image

Looks like a bug https://bugs.launchpad.net/oslo/+bug/... but seems to have fixed.

edit flag offensive delete link more

Comments

Can't seem to find that bug fix page. Any update on how to solve this rootwrap issue ?

tehht gravatar imagetehht ( 2014-10-19 11:40:06 -0500 )edit

@koolhead17 The bug you linked to does not exist. Could you please update with the solution?

Tim gravatar imageTim ( 2014-10-21 14:11:25 -0500 )edit
1

@tehht I solved it for now by installing the upstream version of oslo.rootwrap from pypy with pip install.

Tim gravatar imageTim ( 2014-10-21 14:19:02 -0500 )edit

@Tim thanks for that. I had to run pip install oslo.rootwrap --upgrade to get it to finally work on debian 7.7 (the upgrade being the key point there)

programster gravatar imageprogramster ( 2014-12-10 09:45:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-06-26 09:18:10 -0500

Seen: 2,376 times

Last updated: Jun 30 '14