Ask Your Question
0

ubuntu instance launch error - ovs-vsctl [closed]

asked 2014-06-26 06:05:19 -0500

Xentinel gravatar image

updated 2014-06-26 11:02:54 -0500

smaffulli gravatar image

I've followed the ubuntu OpenStack setup pretty much to the letter, and I'm able to launch the test cirros instance perfectly fine, however when I try to launch "trusty-server-cloudimg-amd64-disk1.img" it throws an error:

Error during following call to agent: ['ovs-vsctl', '--timeout=120', 'del-port', 'br-int', u'qvob81c197a-49']

Since it has to do with ovs-vsctl, I figured it was something on the network node, but there's no mention of it in the openvswitch log files on the network node.

I managed to get it launched using the m1.small flavor instead of m1.tiny

I guess the ubuntu image has some sort of requirement for the root disk size. I can live with that, but I'm just curious of the error.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Xentinel
close date 2014-06-26 19:11:07.056516

Comments

Try restart neutron-openvswitch-agent on this node.
Post /var/log/neutron/openvswitch-agent.log

dbaxps gravatar imagedbaxps ( 2014-06-26 07:06:30 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-06-26 09:44:59 -0500

SGPJ gravatar image

Ubuntu needs at least 2GB (small flavor) to get booted up. You can also use minimal ubuntu or coreOS for tiny flavor. OVS is also present in compute node and it gets connected with neutron server using agent. So try troubleshooting there.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-26 06:05:19 -0500

Seen: 114 times

Last updated: Jun 26 '14