Ask Your Question
0

br-int not responding after few hours

asked 2014-06-26 02:43:06 -0600

kobo gravatar image

updated 2014-06-26 02:44:06 -0600

I have a working multinode icehouse and everything is ok except the dhcp that is not responding after a few hours, when I check tcpdump on br-int that where the dhcp is going throw, there is no traffic at all.
the work around is to restart the network node and everything is working again including the dhcp and traffic is going throw br-int
does anyone encounter an issue like that?

edit retag flag offensive close merge delete

Comments

  1. ps -ef | grep dnsmasq
  2. ip netns exec qdhcp-private-network-id ifconfig ( provides tap interface)
  3. ip netns exec qdhcp-private-network-id tcpdump -ln -i tap-xxxxxxxxxxx
dbaxps gravatar imagedbaxps ( 2014-06-26 03:09:06 -0600 )edit

[root@network-node ~]# ps -ef | grep dnsmasq
nobody 2878 1 0 Jun24 ? 00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tape1015ce7-1d --except-interface=lo --pid-file=/var/lib/neutron/dhcp/39b17a17-e132-46d7-b6ac-a8f0f97ed5d1/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/39b17a17-e132-46d7-b6ac-a8f0f97ed5d1/host --addn-hosts=/var/lib/neutron/dhcp/39b17a17-e132-46d7-b6ac-a8f0f97ed5d1/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/39b17a17-e132-46d7-b6ac-a8f0f97ed5d1/opts --leasefile-ro --dhcp-range=tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

[root@network-node ~]# ip netns exec qdhcp-39b17a17-e132-46d7-b6ac-a8f0f97ed5d1 ifconfig
tape1015ce7-1d Link encap:Ethernet

[root@network-node ~]# ip netns exec qdhcp-39b17a17-e132-46d7-b6ac-a8f0f97ed5d1 tcpdump -ln -i tape1015ce7-1d

no traffic at the tap nor br-int

kobo gravatar imagekobo ( 2014-06-26 04:14:59 -0600 )edit
  1. Set dhcp_lease_time=120 in nova.conf.( just for now, it's harmless)
  2. Post /etc/neutron/plugin.ini ( what kind of Neutron Setup ML2&OVS&VLAN (GRE) , ...)
  3. neutron agent-list
dbaxps gravatar imagedbaxps ( 2014-06-26 04:42:35 -0600 )edit

[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet1:10:100
tunnel_type=gre
tunnel_id_ranges=1000:3000
tenant_network_type=gre
local_ip=192.168.9.25
enable_tunneling=True
integration_bridge=br-int
tunnel_bridge=br-tun
bridge_mappings=physnet1:br-eth1

[AGENT]
polling_interval=2

[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

+--------------------------------------+--------------------+----------+-------+----------------+
| id | agent_type | host | alive | admin_state_up |
+--------------------------------------+--------------------+----------+-------+----------------+
| 1185d134-9aef-4410-93c9-4d5ff2e6390d | Open vSwitch agent | compute-1 | :-) | True |<rb> | 11a1d816-07af-4968-b5a6-3d64e6d7b273 | DHCP agent | network-node | :-) | True |
| 73e977b6-373f-4020-81bc-b636ed4cc624 | Metadata agent | network-node | :-) | True |
| 823949c5-9bca-4b3c-921d-30f2134a9c9d | Open vSwitch agent | controller | :-) | True |
| a23a103d-0766-4fe0-adf1-acc29125d8e8 | L3 agent | network-node | :-) | True |
| b3335b5f-e3ce-42c1-9b39-6b999fa3a174 | Open vSwitch agent | network-node | :-) | True |
| d7322465-cc6e-4500-990b-86c1a91ce4df | Open vSwitch agent | compute-2 | :-) | True |
+--------------------------------------+--------------------+----------+-------+----------------+

kobo gravatar imagekobo ( 2014-06-26 06:01:47 -0600 )edit

Correct sample bellow :-

[root@icehouse1 neutron]# cat plugin.ini
[ovs]
[agent]
tunnel_types =gre
[securitygroup]
[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet1
tunnel_type=gre
tunnel_id_ranges=1:1000
tenant_network_type=gre
local_ip=192.168.0.127
enable_tunneling=True
integration_bridge=br-int
tunnel_bridge=br-tun
[AGENT]
polling_interval=2
[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
dbaxps gravatar imagedbaxps ( 2014-06-26 06:32:15 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-09-10 07:04:08 -0600

kobo gravatar image

The issue was internal routing in the network node.
http://brainscraps.wikia.com/wiki/Set...

once that fixed this issue was resolved

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-26 02:43:06 -0600

Seen: 165 times

Last updated: Jun 26 '14