Ask Your Question

VMs on Controller Node can't properly send/recieve broadcasts

asked 2013-07-22 14:23:12 -0500

jzwiep gravatar image

On our private OpenStack essex cloud (single host, flatDHCP networking), VMs spawned on the controller can't properly send or receive broadcasts (looks like a NAT), while VMs spawned on the compute nodes don't experience any issues at all.

We have two independent networks:

Network 1:

Network 2:

and the VMs are all connected to 'network 1' and are given addresses in the subnet When a broadcast is sent from a VM on the controller node, machines on 'network 1' see it as being sent from the controller's 'network 2' interface address. Simlararly, when a broadcast is sent from a machine on 'network 1' a VM on the controller node will see it as being sent from the controller's 'network 2' interface address.

This does not happen at all on the compute node guests.

Our config setup:

/etc/network/interfaces (eth0 is connected to 'network 1', eth1 to 'network 2')

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

auto lo
iface lo inet loopback

# eth0 is not defined here, because it is used in the bridge
auto eth1
iface eth1 inet dhcp

auto eth0
iface eth0 inet dhcp

auto br100
iface br100 inet dhcp
        bridge_ports eth0
        bridge_stp off
        bridge_maxwait 0
        bridge_fd 0


--root_helper=sudo nova-rootwrap

# vnc specific configuration

# network specific settings

# RabbitMQ settings

# Metadata settings

iptables for instance on controller

Chain nova-compute-inst-229 (1 references)
target     prot opt source               destination
DROP       all  --  anywhere             anywhere             state INVALID
ACCEPT     all  --  anywhere             anywhere             state RELATED,ESTABLISHED
nova-compute-provider  all  --  anywhere             anywhere
ACCEPT     udp  --           anywhere             udp spt:bootps dpt:bootpc
ACCEPT     all  --        anywhere
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:3389
ACCEPT     icmp --  anywhere             anywhere
ACCEPT     tcp  --  anywhere             anywhere             multiport dports 50080:50110
ACCEPT     udp ...
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2013-07-24 20:47:41 -0500

jzwiep gravatar image

Managed to fix it.

I corrected the fixed_range in nova.conf to match nova's network, and added this config option:


This stops VM traffic from getting SNATTED (

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-07-22 14:23:12 -0500

Seen: 272 times

Last updated: Jul 24 '13