Ask Your Question
0

devstack dashboard returns to login screen even if the login is successful

asked 2014-06-25 10:51:45 -0500

RedCricket gravatar image

updated 2014-06-25 10:54:48 -0500

Hi,

I was able to successfully run stack.sh on my centos 6.5 system ...

$ ./stack.sh

... lots of output ...

Horizon is now available at http://192.168.163.129/
Keystone is serving at http://192.168.163.129:5000/v2.0/
Examples on using novaclient command line is in exercise.sh
The default users are: admin and demo
The password: redacted
This is your host ip: 192.168.163.129
2014-06-24 16:51:38.739 | stack.sh completed in 583 seconds.

... but when I go to http://192.168.163.129/ and login as admin I just get re-directed back to the login screen. I can see this in the horizon log files ...

[root@localhost httpd]# tail -f horizon_access.log
...
127.0.0.1 - - [25/Jun/2014:02:02:16 -0700] "POST /auth/login/ HTTP/1.1" 302 - "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20131029 Firefox/17.0"
127.0.0.1 - - [25/Jun/2014:02:02:19 -0700] "GET / HTTP/1.1" 200 1771 "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20131029 Firefox/17.0"
127.0.0.1 - - [25/Jun/2014:02:02:20 -0700] "GET /static/dashboard/css/54df006a8f74.css HTTP/1.1" 200 152200 "http://localhost/" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20131029 Firefox/17.0"

[root@localhost httpd]# tail -f horizon_error.log
[Tue Jun 24 23:27:41 2014] [error] Login successful for user "admin".
[Tue Jun 24 23:31:40 2014] [error] Login successful for user "admin".
[Tue Jun 24 23:32:02 2014] [error] Login successful for user "demo".
[Tue Jun 24 23:32:16 2014] [error] Login successful for user "admin".
[Tue Jun 24 23:43:22 2014] [error] DeprecationWarning: Translations in the project directory aren't supported anymore. Use the LOCALE_PATHS setting instead.Not Found: /favicon.ico
[Tue Jun 24 23:43:23 2014] [error] Not Found: /favicon.ico
[Tue Jun 24 23:43:32 2014] [error] Not Found: /static/dashboard
[Tue Jun 24 23:43:43 2014] [error] Not Found: /static/
[Wed Jun 25 08:52:09 2014] [error] Login successful for user "admin".
[Wed Jun 25 09:02:19 2014] [error] DeprecationWarning: Authentication backends without a `supports_inactive_user` attribute are deprecated. Please define it in <class 'openstack_auth.backend.KeystoneBackend'>.Login successful for user "admin".

Can anyone tell me what I am doing wrong?

thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-25 15:34:44 -0500

mpetason gravatar image

You may want to look at installing it again. Are you using all of options available and installing all of the keystone endpoints? This used to happen in Havana when there were more than 8 endpoints. The token size was too large and it would "login" but would end up failing. I fixed this before by setting up the Dashboard to use a DB backend instead of MemCached. If you are using Devstack + Icehouse then you should be able to modify the .conf files for the services you installed and add :

max_header_line = 16384

You could look over bug reports for devstack and see if it has been reported. I wasn't able to track down actual errors when this occurred, just the symptoms.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-25 10:51:45 -0500

Seen: 1,429 times

Last updated: Jun 25 '14