Ask Your Question
2

libjs-swfobject and novnc

asked 2013-07-22 03:24:55 -0600

anonymous user

Anonymous

updated 2013-07-22 03:35:01 -0600

hi i am using grizzly edition for installation below packages:

sudo apt-get install nova-novncproxy novnc nova-api nova-ajax-console-proxy nova-cert nova-conductor nova-consoleauth nova-doc nova-scheduler nova-network

but i get an error that novnc is depended to libjs-swfobject package. of course this package is not in http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/grizzly main

so i am using repo ( http://ftp.de.debian.org/debian sid main ) for installing that package. Is it not mentioned any thing about this issue. by doing this work i successfully install novnc and others.

my question : Is it true ??

edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
4

answered 2013-08-17 01:32:15 -0600

Rahul Patil gravatar image

updated 2013-08-17 01:36:28 -0600

Cred to @Kui,

Here is simple to steps to install:

wget http://archive.ubuntu.com/ubuntu/pool/universe/libj/libjs-swfobject/libjs-swfobject_2.2+dfsg-1_all.deb

dpkg -i libjs-swfobject_2.2+dfsg-1_all.deb

aptitude install nova-novncproxy novnc
edit flag offensive delete link more
2

answered 2013-07-27 21:37:19 -0600

Kui gravatar image

updated 2013-08-18 08:44:02 -0600

Jobin gravatar image

Two methods to resolve this problem:

  • Download libjs-swfobject and install it manually

I get novcn search result, the "sid(unstable)" support few arch, I select the wheezy(stable) . Download the .deb file for your arch, install it manually:

$ sudo dpkg -i libjs-swfobject_2.2+dfsg-1_all.deb

$ sudo apt-get install -y novnc
  • Using debian wheezy sources.list

Choose a wheezy sources.list, paste it into a file: /etc/apt/sources.list.d/wheezy.list

$ sudo apt-get update

$ sudo apt-get install -y novnc
edit flag offensive delete link more
0

answered 2013-08-28 22:06:51 -0600

网名还没想好 gravatar image

it also solved my problem,thanks

edit flag offensive delete link more
0

answered 2013-08-21 19:17:41 -0600

eecszhu gravatar image

second approach needs to add public keys

gpg --recv-keys KEY-ID gpg --armor --export KEY-ID | apt-key add -

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-22 03:24:55 -0600

Seen: 1,536 times

Last updated: Aug 28 '13