DHCP discover does not arrive on the tap/qvo interface [closed]

asked 2014-06-24 08:17:29 -0500

vyom gravatar image

updated 2014-06-24 08:21:45 -0500

Hello,

I have a --allinone Icehouse setup. Things worked fine until, I changed the firewall driver (i.e, I replaced with NoopFirewallDriver and did a reboot of my host. After that, the instances do not get IP addresses. I tried to debug, following all the suggestions/tips/workarounds that I could find (like delete and re-create br-int , ensure no IP is configured on br-int etc). So far, I have not been able to find what could be causing this!

I see that the tap interface on which dnsmasq is supposed to get the requests, is not receiving packets,

# cat /proc/10783/cmdline | tr '\0' '\n'
dnsmasq
--no-hosts
--no-resolv
--strict-order
--bind-interfaces
--interface=tapa3019305-5d  <--- Packets are not getting here!
--except-interface=lo
--pid-file=/var/lib/neutron/dhcp/6ff87d22-cd90-40d2-b6fd-bd79b54c4c0b/pid
--dhcp-hostsfile=/var/lib/neutron/dhcp/6ff87d22-cd90-40d2-b6fd-bd79b54c4c0b/host <---I can see the instances MAC and the IP to be assigned, here
--addn-hosts=/var/lib/neutron/dhcp/6ff87d22-cd90-40d2-b6fd-bd79b54c4c0b/addn_hosts
--dhcp-optsfile=/var/lib/neutron/dhcp/6ff87d22-cd90-40d2-b6fd-bd79b54c4c0b/opts
--leasefile-ro
--dhcp-range=tag0,10.193.0.0,static,86400s 
--dhcp-lease-max=65536
--conf-file=
--domain=openstacklocal

this is because, the qvo corresponding to that tap, which is on br-int is not receiving any packets

# tcpdump -ln -i qvo8fd09f1e-19
tcpdump: WARNING: qvo8fd09f1e-19: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on qvo8fd09f1e-19, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

Here is the br-int:

    Bridge br-int
        Port int-br-ex
            Interface int-br-ex
        Port "tapa3019305-5d"
            tag: 3
            Interface "tapa3019305-5d"
                type: internal
        Port "qvo8fd09f1e-19" <--- culprit
            tag: 3
            Interface "qvo8fd09f1e-19"
          ...

Whereas the packets seem to be sent out from the instances' tap:

# tcpdump -ln -i tap8fd09f1e-19
tcpdump: WARNING: tap8fd09f1e-19: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tap8fd09f1e-19, link-type EN10MB (Ethernet), capture size 65535 bytes
17:48:55.318016 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from fa:16:3e:03:00:a0, length 280
...

The network which I am trying to use, is of type flat, and I have security group rules allowing ingress/TCP and ingress/ICMP.

One more thing I observe, is:

# ovs-ofctl show br-int
OFPT_FEATURES_REPLY (xid=0x2): dpid:00009a525e0b4b4e
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(tap65017795-ab): addr:4e:01:00:00:00:00
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 2(tapa3019305-5d): addr:4e:01:00:00:00:00
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 3(tap40536167-fe): addr:52:01:00:00:00:00
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max

I tried to ip link set <> up and ifconfig <> up the tap interfaces, but still I see the PORT_DOWN and LINK_DOWN states - is this the cause ? Or am I looking in the wrong direction? Any help, or pointers to debug further, much appreciated.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2015-01-20 09:54:48.096050

Comments

I would suggest you keep all *.conf files as they have been created by packstack --allinione install.
You followed http://docs.openstack.org/havana/inst... on RH's system.

dbaxps gravatar imagedbaxps ( 2014-06-24 12:00:09 -0500 )edit

@dbaxps, I don't have any other changes (before and after my reboot), except for the NoopFirewall change. BTW, after packstack --allinone, I made only a few changes for creation of the networks (like adding physnet1, physnet2 etc, and with that, everything was working fine.

vyom gravatar imagevyom ( 2014-06-24 12:07:51 -0500 )edit

Did packstack setup firewall_driver=nova.virt.firewall.NoopFirewallDriver in nova.conf ?
I believe no. What for you did it ?

dbaxps gravatar imagedbaxps ( 2014-06-24 12:47:05 -0500 )edit

@dbaxps, I didnt want to have a firewall config, hence I removed it. A similar config is working for my teammate, on Ubuntu (2-node setup). In my case, I am on RDO and single-node. From what you said, do you mean to suggest that --allinone and NoopFireWall, do not go well together?, or that I am missing some other config to make sure NoopFirewall works?. Thanks anyway, as a last resort, I will go back to original config (as generated by packstack)

vyom gravatar imagevyom ( 2014-06-25 00:16:46 -0500 )edit

@vyom, wondering if you've made any progress since posting this, and, if so, what you ended up doing?

rbowen gravatar imagerbowen ( 2014-12-08 14:35:44 -0500 )edit