Ask Your Question
0

Loadbalancer agent shown as not alive

asked 2014-06-23 00:11:50 -0500

vyom gravatar image

updated 2014-07-01 01:42:43 -0500

Hello,

After the reboot of my host (--allinone), I see that Loadbalancer agent state is shown as xxx (not alive), even though neutron-lbaas-agent is running. I see the following in the log though:

Timeout: Timeout while waiting on RPC response - topic: "n-lbaas-plugin", RPC method: "get_ready_devices" info: "<unknown>"

rabbitmq is also up and running, and I have the following in my neutron.conf

report_interval = 30
agent_down_time = 75

what else should I check?

--EDIT-2014/7/1--

Even with state being shown xxx, the functionality is not affected.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-23 01:33:20 -0500

LBAAS agent is not enabled when you use RDO Packstack to install OpenStack Icehouse.

I used the steps from http://docs.openstack.org/admin-guide-cloud/content/install_neutron-lbaas-agent.html (http://docs.openstack.org/admin-guide...) to enable it on the network node. Replace apt-get with yum (yum install neutron-lbaas-agent). Also make sure haproxy is installed (yum install haproxy).

Run the following to enable the service (after httpd and neutron services are restarted):

service neutron-lbaas-agent start

chkconfig neutron-lbaas-agent on

edit flag offensive delete link more

Comments

@Kunal, I had HaProxy installed and running, and then I replaced it with my own driver. Even with my driver, I had the agent status as up. After a host reboot, I am seeing this issue.

vyom gravatar imagevyom ( 2014-06-23 04:16:38 -0500 )edit

Similar issue faced earlier: https://ask.openstack.org/en/question/13226/lbaas-unable-to-retrieve-ready-devices/ (https://ask.openstack.org/en/question...) . You may try a few things from here. What happens when you restart the neutron-lbaas-agent service? Also, it would help to get extra info in logs by setting debug true in the conf files.

KunalTPatil gravatar imageKunalTPatil ( 2014-06-23 04:40:19 -0500 )edit

Check for this bug. I think it might help: https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1022725 (https://bugzilla.redhat.com/show_bug....) [Assuming there is some error in the /var/log/neutron/server.log file as well]

KunalTPatil gravatar imageKunalTPatil ( 2014-06-23 22:47:15 -0500 )edit

Summarised steps. I faced similar problems in the morning. There are some bugs you need to work around. http://itinsteps.blogspot.in/2014/06/steps-to-configure-neutron-lbaas-agent.html (http://itinsteps.blogspot.in/2014/06/...)

KunalTPatil gravatar imageKunalTPatil ( 2014-06-24 00:26:25 -0500 )edit

@Kunal, as mentioned earlier, I am not using HAProxy; I have my own LBaaS driver. Also, I dont have service_provider config in neutron-dist.conf

vyom gravatar imagevyom ( 2014-06-24 12:01:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-23 00:11:50 -0500

Seen: 624 times

Last updated: Jul 01 '14