Ask Your Question
-1

DHCP from instance is not reaching the DHCP Server

asked 2014-06-22 06:38:45 -0500

diegolopez gravatar image

updated 2014-06-22 07:41:54 -0500

dbaxps gravatar image

I'm trying to configure Neutron with OpenvSwitch and GRE tunneling, with 2 servers: One of them it's a controller and compute node, and the other it's only a compute node.

When OpenStack launch the instance into the controller, it's OK, the instance has IP, but when it's launched into the other, the instance is configured without IP, but I can see in Horizon that this instance has IP (for example I can see 10.0.0.100 but when I do "ifconfig" in the instance, it hasn't got IP and I can't ping on it).

I'm using KVM with Libvirth. My controller has 192.168.122.200, and the compute 192.168.122.201.

Controller: /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:
[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet:1000:2000
local_ip=192.168.122.201
enable_tunneling=True
integration_bridge=br-int
tunnel_type=gre
tunnel_id_ranges=1:1000
tunnel_bridge=br-tun
tenant_network_type=gre

[AGENT]
polling_interval=2

[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

Compute: /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:
[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet:1000:2000
local_ip=192.168.122.201
enable_tunneling=True
integration_bridge=br-int
tunnel_type=gre
tunnel_id_ranges=1:1000
tunnel_bridge=br-tun
tenant_network_type=gre

[AGENT]
polling_interval=2

[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver


neutron agent-list:

+--------------------------------------+--------------------+------------+-------+----------------+

| id                                   | agent_type         | host       | alive | admin_state_up |

+--------------------------------------+--------------------+------------+-------+----------------+

...

| 2824eb92-eec8-4731-b432-b1960cd8c4e8 | Open vSwitch agent | comp1      | :-)   | True           |

| 730e40e2-f9db-4281-9418-caf3bebf990e | Open vSwitch agent | controller | :-)   | True           |

...

+--------------------------------------+--------------------+------------+-------+----------------+


Any ideas? Thanks!
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-22 08:10:39 -0500

dbaxps gravatar image

updated 2014-06-22 10:05:31 -0500

Here goes ready solution for CentOS 6.5 or F20. Configuration and *.ini  files should work on Ubuntu as well.
Two Real Node (Controller+Compute) IceHouse Neutron OVS&GRE Cluster on Fedora 20


http://bderzhavets.blogspot.com/2014/...
http://bderzhavets.blogspot.com/2014/...

[root@icehouse1 neutron]# cat plugin.ini
[ovs]
[agent]
tunnel_types =gre
[securitygroup]
[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet1
tunnel_type=gre
tunnel_id_ranges=1:1000
tenant_network_type=gre
local_ip=192.168.0.127
enable_tunneling=True
integration_bridge=br-int
tunnel_bridge=br-tun
[AGENT]
polling_interval=2
[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
edit flag offensive delete link more
0

answered 2014-06-23 16:11:03 -0500

diegolopez gravatar image

not work, I set tunnel_types =gre, but it still doesn't work

I create this external-net:

neutron net-create ext-net --shared --router:external=True neutron subnet-create ext-net --allocation-pool start=192.168.122.100,end=192.168.122.150 --gateway=192.168.122.200 --enable_dhcp=True 192.168.122.0/24

When I see ext-net (neutron net-show ext-net) , the provider is local !!

provider:network_type local

If I try to change it, for example creating another like this, it throws an exception:

neutron net-create net2 --provider:network-type gre

400-{u'NeutronError': {u'message': u'Invalid input for operation: gre networks are not enabled.', u'type': u'InvalidInput', u'detail': u''}}

It seems like OVS don't get the config file. And when I restart OVS, in the openvswitch-agent.log:

2014-06-23 23:09:02.195 1958 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Error while processing VIF ports 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent Traceback (most recent call last): 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/agent/ovs_neutron_agent.py", line 1213, in rpc_loop 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent port_info = self.scan_ports(ports, updated_ports_copy) 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/agent/ovs_neutron_agent.py", line 816, in scan_ports 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent cur_ports = self.int_br.get_vif_port_set() 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/ovs_lib.py", line 311, in get_vif_port_set 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent port_names = self.get_port_name_list() 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/ovs_lib.py", line 267, in get_port_name_list 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent res = self.run_vsctl(["list-ports", self.br_name], check_error=True) 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/ovs_lib.py", line 74, in run_vsctl 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent ctxt.reraise = False 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/excutils.py", line 82, in __exit__ 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent six.reraise(self.type_, self.value, self.tb) 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/ovs_lib.py", line 67, in run_vsctl 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent return utils.execute(full_args, root_helper=self.root_helper) 2014-06-23 23:09:02.195 1958 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/utils.py", line 76, in execute ... (more)

edit flag offensive delete link more

Comments

You wrote : I'm using KVM with Libvirth. My controller has 192.168.122.200, and the compute 192.168.122.201. to setup Two Node Neutron OVS&GRE . What OS are your Controller&Compute running ?
Next " --gateway=192.168.122.200" is mistake for Libvirts Subnet

dbaxps gravatar imagedbaxps ( 2014-06-23 21:59:39 -0500 )edit

Ubuntu 14.04 . I changed this gateway by 192.168.122.1, but it still not work.

diegolopez gravatar imagediegolopez ( 2014-06-23 23:28:20 -0500 )edit

Post /etc/neutron/plugin.ini

dbaxps gravatar imagedbaxps ( 2014-06-23 23:40:37 -0500 )edit

it's in the first comment. it's a link that points to /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini

diegolopez gravatar imagediegolopez ( 2014-06-24 02:10:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-22 06:38:45 -0500

Seen: 617 times

Last updated: Jun 23 '14