Ask Your Question
3

Plugin ml2 configuration for neutron on icehouse, debian wheezy

asked 2014-06-20 03:03:46 -0500

dwyaneini gravatar image

updated 2014-06-26 19:54:30 -0500

I'm configuring Neutron to use ml2 plugin. As described in the official documentation, I set the core_plugins. But when I tried to restart the service neutron-plugin-openvswitch-agent, it prompts

 Plugin not recognized: please edit /etc/init.d/neutron-server to select the correct .ini file to load for your plugin 
 [....]      
 Restarting Openstack Neutron OpenVSwitch Plugin Agent: neutron-openvswitch-agentstart-stop-daemon: warning: failed to kill 3166: No such process

so I did. Then when I restart neutron-l3-agent, neutron-dhcp-agent and neutron-metadata-agent services, all of them say warning: failed to kill xxx: No such process.

What's puzzling is that when I configure the Neutron with network type "local " rather than "gre", the restart of above-mentioned services work and the networks creation works, too.

Thanks, all.

edit retag flag offensive close merge delete

Comments

am getting the same warning message (without the failed to kill). I don't seem to have any whitespaces in my configuration files (rgrep '^ ' *.ini)

Any ideas of another fix for this ?

arthur.lutz ( 2014-08-25 10:05:20 -0500 )edit

@arthur.lutz first, you can search log files of neutron-relevant services for any useful relative information. If there's no, you'd better recheck your configuration of neutron-relevant services. According to my experiences, any tiny change of configurations may lead to start abnormally.

dwyaneini ( 2014-08-25 22:19:12 -0500 )edit

@arthur.lutz So, you'd better check your configuration carefully. Then start your services, you can use command "service SERVICE_NAME status" to see the running status of service.

dwyaneini ( 2014-08-25 22:20:54 -0500 )edit

@dwyaneini neutron-server seem to be running although I still can't launch any VMs. Am trying to track down my error, which might be network related.

service neutron-server status says neutron-seneutron-server is running. preceeded by the "Plugin not recognized..."

arthur.lutz ( 2014-08-26 03:18:54 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-25 21:52:55 -0500

dwyaneini gravatar image

I have solved this problem. This is caused by low level details of configuration.

I use the neutron-db-manage --configure-file to direct the configuration **.ini to neutron.conf. Then it prompts me that oslo.config.cfg.ConfigFileParseError: Failed to parse /etc/neutron/neutron.conf. I find this is a "bug" in parsing configration file when there are white spaces on the beginning of lines, more details see link https://bugs.launchpad.net/oslo/+bug/... .

After modifying all blanks in configuration files, I try to restart the service neutron-plugin-openvswitch-agent, it's ok. At the meantime, I see the status of the service, it is actually running.

Though it has been solved, but when I try to modify the configuration file, the warning: "failed to kill 3166: No such process " will usually turn up.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-06-20 03:03:46 -0500

Seen: 468 times

Last updated: Jun 26 '14