how http://127.0.0.1:35357 become http://127.0.0.1=35357 when using keystone user-list?

asked 2014-06-19 14:59:03 -0500

Fábio Chicout gravatar image

updated 2014-06-25 08:51:22 -0500

Installing keystone on Centos 6.5, everything was fine, and user-create, role-create, tenant-create, and token get commands running fine but when I run keystone user-list, it returned

Authorization Failed: Unable to estabilish connection to http://127.0.0.1=35357/v2.0

It doesn't matter if the url is passed from the --os-auth-url parameter or by the environment variable $OS_AUTH_URL, it changes the ':' for a '='. The /etc/keystone/keystone.conf was not modified from keystone install.

Running with debug option:

DEBUG:keystoneclient.session:REQ: curl -i -X POST http://os-controller:35357/v2.0/tokens -H "Content-Type: application/json" -H "Accept: application/json" -H "User-Agent: python-keystoneclient" -d '{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "admin", "password": "suporteUfpe"}}}' INFO:urllib3.connectionpool:Starting new HTTP connection (1): os-controller DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 2513 DEBUG:keystoneclient.session:RESP: [200] {'date': 'Fri, 20 Jun 2014 20:24:50 GMT', 'content-type': 'application/json', 'content-length': '2513', 'vary': 'X-Auth-Token'} RESP BODY: {"access": {"token": {"issued_at": "2014-06-20T20:24:50.078038", "expires": "2014-06-20T21:24:50Z", "id": "MIIE9QYJKoZIhvcNAQcCoIIE5jCCBOICAQExCTAHBgUrDgMCGjCCA0sGCSqGSIb3DQEHAaCCAzwEggM4eyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wNi0yMFQyMDoyNDo1MC4wNzgwMzgiLCAiZXhwaXJlcyI6ICIyMDE0LTA2LTIwVDIxOjI0OjUwWiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogIjk3MDNhNjk1YmI5ODQ2YjViMzczZGJkNDA0M2NiMDg1IiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9vcy1jb250cm9sbGVyPTM1MzU3L3YyLjAiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vb3MtY29udHJvbGxlcjo1MDAwL3YyLjAiLCAiaWQiOiAiMTA2YWVkZmZjYTY1NGVjNGI2NWU3YTk2MTU5ZTYwMzYiLCAicHVibGljVVJMIjogImh0dHA6Ly9vcy1jb250cm9sbGVyOjUwMDAvdjIuMCJ9XSwgImVuZHBvaW50c19saW5rcyI6IFtdLCAidHlwZSI6ICJpZGVudGl0eSIsICJuYW1lIjogImtleXN0b25lIn1dLCAidXNlciI6IHsidXNlcm5hbWUiOiAiYWRtaW4iLCAicm9sZXNfbGlua3MiOiBbXSwgImlkIjogIjM0M2RmNGVlMDA3MDRjYjM4YjI4MTE1YmE3ZWY5YzE0IiwgInJvbGVzIjogW3sibmFtZSI6ICJfbWVtYmVyXyJ9LCB7Im5hbWUiOiAiYWRtaW4ifV0sICJuYW1lIjogImFkbWluIn0sICJtZXRhZGF0YSI6IHsiaXNfYWRtaW4iOiAwLCAicm9sZXMiOiBbIjlmZTJmZjllZTQzODRiMTg5NGE5MDg3OGQzZTkyYmFiIiwgIjVmNDc3YThjZGJkYjRlMzdiYjNhNjMwMWFhMzFiZWUyIl19fX0xggGBMIIBfQIBATBcMFcxCzAJBgNVBAYTAlVTMQ4wDAYDVQQIDAVVbnNldDEOMAwGA1UEBwwFVW5zZXQxDjAMBgNVBAoMBVVuc2V0MRgwFgYDVQQDDA93d3cuZXhhbXBsZS5jb20CAQEwBwYFKw4DAhowDQYJKoZIhvcNAQEBBQAEggEAdFfqF+wnI6-0zh4lJCla5JQ8qVt77YYJNLy4gjbOx1ez5LdXEFrsJdpdVMLXNqNH2vrtpwJP8f17mX49RzhC5Ys916L2rsrr9Nj6EnnVRK1I7wmiAaJBiENomfV8wvh6T7wn43bfltlDWaFks3RZ1Nsp-3NDsjsIsBBtnDE2NX5EY8OZPz30lP7M4FLP9JFowSyKz1vZdtjA3L0ucfqEuXC-RxM+HQptZ0UNJlAv5FB9hJOjkFfRwBT2i-a5ovPBCWA7qFBwvd1k46jjtQgWCfDrp8m-C0qctBI207q6Axo-KYCajX1qj3+njxiu-hT9SQK6QtlnxuNwKco2DxPK-A==", "tenant": {"description": "Admin Tenant", "enabled": true, "id": "9703a695bb9846b5b373dbd4043cb085", "name": "admin"}}, "serviceCatalog": [{"endpoints": [{"adminURL": "http://os-controller=35357/v2.0", "region": "regionOne", "internalURL": "http://os-controller:5000/v2.0", "id": "106aedffca654ec4b65e7a96159e6036", "publicURL": "http://os-controller:5000/v2.0"}], "endpoints_links": [], "type": "identity", "name": "keystone"}], "user": {"username": "admin", "roles_links": [], "id": "343df4ee00704cb38b28115ba7ef9c14", "roles": [{"name": "_member_"}, {"name": "admin"}], "name": "admin"}, "metadata": {"is_admin": 0, "roles": ["9fe2ff9ee4384b1894a90878d3e92bab", "5f477a8cdbdb4e37bb3a6301aa31bee2"]}}}

DEBUG:iso8601.iso8601:Parsed 2014-06-20T21:24:50Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'21', 'daydash': u'20', 'tz_hour': None, 'month': None, 'timezone': u'Z', 'second': u'50', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'monthdash': u'06', 'day': None, 'minute': u'24'} with default timezone DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None DEBUG:iso8601.iso8601:Got u'06' for 'monthdash' with default 1 DEBUG:iso8601.iso8601:Got 6 for 'month' with default 6 DEBUG:iso8601.iso8601:Got u'20' for 'daydash' with default 1 DEBUG:iso8601.iso8601:Got 20 for 'day' with default 20 DEBUG:iso8601.iso8601:Got u'21' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'24' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'50' for 'second' with default None DEBUG:keystoneclient.session:REQ: curl -i -X GET http://os-controller=35357/v2.0/endpo... -H "User-Agent: python-keystoneclient" -H "X-Auth-Token: MIIE9QYJKoZIhvcNAQcCoIIE5jCCBOICAQExCTAHBgUrDgMCGjCCA0sGCSqGSIb3DQEHAaCCAzwEggM4eyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNC0wNi0yMFQyMDoyNDo1MC4wNzgwMzgiLCAiZXhwaXJlcyI6ICIyMDE0LTA2LTIwVDIxOjI0OjUwWiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogIjk3MDNhNjk1YmI5ODQ2YjViMzczZGJkNDA0M2NiMDg1IiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly9vcy1jb250cm9sbGVyPTM1MzU3L3YyLjAiLCAicmVnaW9uIjogInJlZ2lvbk9uZSIsICJpbnRlcm5hbFVSTCI6ICJodHRwOi8vb3MtY29udHJvbGxlcjo1MDAwL3YyLjAiLCAiaWQiOiAiMTA2YWVkZmZjYTY1NGVjNGI2NWU3YTk2MTU5ZTYwMzYiLCAicHVibGljVVJMIjogImh0dHA6Ly9vcy1jb250cm9sbGVyOjUwMDAvdjIuMCJ9XSwgImVuZHBvaW50c19saW5rcyI6IFtdLCAidHlwZSI6ICJpZGVudGl0eSIsICJuYW1lIjogImtleXN0b25lIn1dLCAidXNlciI6IHsidXNlcm5hbWUiOiAiYWRtaW4iLCAicm9sZXNfbGlua3MiOiBbXSwgImlkIjogIjM0M2RmNGVlMDA3MDRjYjM4YjI4MTE1YmE3ZWY5YzE0IiwgInJvbGVzIjogW3sibmFtZSI6ICJfbWVtYmVyXyJ9LCB7Im5hbWUiOiAiYWRtaW4ifV0sICJuYW1lIjogImFkbWluIn0sICJtZXRhZGF0YSI6IHsiaXNfYWRtaW4iOiAwLCAicm9sZXMiOiBbIjlmZTJmZjllZTQzODRiMTg5NGE5MDg3OGQzZTkyYmFiIiwgIjVmNDc3YThjZGJkYjRlMzdiYjNhNjMwMWFhMzFiZWUyIl19fX0xggGBMIIBfQIBATBcMFcxCzAJBgNVBAYTAlVTMQ4wDAYDVQQIDAVVbnNldDEOMAwGA1UEBwwFVW5zZXQxDjAMBgNVBAoMBVVuc2V0MRgwFgYDVQQDDA93d3cuZXhhbXBsZS5jb20CAQEwBwYFKw4DAhowDQYJKoZIhvcNAQEBBQAEggEAdFfqF+wnI6-0zh4lJCla5JQ8qVt77YYJNLy4gjbOx1ez5LdXEFrsJdpdVMLXNqNH2vrtpwJP8f17mX49RzhC5Ys916L2rsrr9Nj6EnnVRK1I7wmiAaJBiENomfV8wvh6T7wn43bfltlDWaFks3RZ1Nsp-3NDsjsIsBBtnDE2NX5EY8OZPz30lP7M4FLP9JFowSyKz1vZdtjA3L0ucfqEuXC-RxM+HQptZ0UNJlAv5FB9hJOjkFfRwBT2i-a5ovPBCWA7qFBwvd1k46jjtQgWCfDrp8m-C0qctBI207q6Axo-KYCajX1qj3+njxiu-hT9SQK6QtlnxuNwKco2DxPK-A==" INFO:urllib3.connectionpool:Starting new HTTP connection (1): os-controller=35357 Unable to establish connection to http://os-controller=35357/v2.0/endpo...

edit retag flag offensive close merge delete

Comments

1

Can you run with debug option? That should give you a clue.
keystone --debug user-list

Haneef Ali gravatar imageHaneef Ali ( 2014-06-19 22:11:23 -0500 )edit

I had run with the debug option. It looks like it does a first curl post, and it is fine, the URL is ok. At this request looks like it takes the auth token from login. Then it does another curl to the same address, but now it changes the ':' to '=' char.

Fábio Chicout gravatar imageFábio Chicout ( 2014-06-24 01:25:34 -0500 )edit

Can you post the complte output?

Haneef Ali gravatar imageHaneef Ali ( 2014-06-24 12:31:14 -0500 )edit

Is that how you have it setup in your openrc? If you list environment variables does it still store it due to a mistype previously?

Verify what you have setup in your openrc file (assuming you have one sourced) and verify what is in the environment variables for your session.

mpetason gravatar imagempetason ( 2014-06-25 12:07:51 -0500 )edit

3 answers

Sort by » oldest newest most voted
1

answered 2014-06-20 16:09:55 -0500

smaffulli gravatar image

Looks like a typo somewhere. Check what's in keystone.conf even if it wasn't changed and increase verbosity of your client (check the logs too, just in case). Edit the question and paste the command you're using to invoke keystone.

edit flag offensive delete link more

Comments

Tried reviewing all the keystone confs, but nothing found. To cleanse my consience, I've done a grep -R for \=35357 for /. Nothing found.

Fábio Chicout gravatar imageFábio Chicout ( 2014-06-25 08:50:03 -0500 )edit
2

answered 2014-06-25 12:22:48 -0500

updated 2014-06-25 12:23:33 -0500

Look at your admin_url in the service catalog. That has "=" sign. The client will take the identity service url from the token response

: [{"endpoints": [{"adminURL": "http://os-controller=35357/v2.0", "region": "regionOne", "internalURL": "http://os-controller:5000/v2.0", "id": "106aedffca654ec4b65e7a96159e6036", "publicURL": "http://os-controller:5000/v2.0"}], "endpoints_links": [], "type": "identity", "name": "keystone"}
edit flag offensive delete link more

Comments

Great post. I wasn't even thinking about that when he brought up the error. I was only thinking of it at the openrc level.

mpetason gravatar imagempetason ( 2014-06-25 20:58:58 -0500 )edit
1

answered 2014-06-25 21:21:00 -0500

Fábio Chicout gravatar image

Guys, thanks for pointing your comments! What Haneef Ali said gives me the definitive clue to fix the issue.

I've logged on MySQL, and updated on the keystone database the adminUrl directly, with the SQL:

 update endpoint set url='http://os-controller:35357/v2.0' where interface='admin';

Restarted it all and everything went fine!

This was needed because this error messed all the *-list commands (as far as I could see).

Thanks again!

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-19 14:59:03 -0500

Seen: 1,120 times

Last updated: Jun 25 '14