Ask Your Question
0

keystone.common.wsgi [-] Authorisation failed. The request you made requires authentication. from 127.0.0.1

asked 2014-06-19 12:05:57 -0500

Medou gravatar image

When i verify that authorization is behaving as expected by requesting authorization on a tenant:
$ keystone --os-username=admin --os-password=ADMIN_PASS --os-tenant-name=admin --os-auth-url=http://controller:35357/v2.0 token-get

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
1

answered 2014-06-19 12:15:57 -0500

First make sure your username password is correct.

  • Step1 : Try to authenticate without os-tenant-name parameter. If your username/pwd is correct then it should work. Make sure you are not passing tenant-name via environment variable. Unset the OS_TENANT_NAME keystone --os-username=admin --os-password=ADMIN_PASS --os-auth-url=http://controller:35357/v2.0 token-getstrong text

  • Step 2: If step 1 works then try authentication with tenant name keystone --os-username=admin --os-password=ADMIN_PASS --os-tenant-name=admin --os-auth-url=http://controller:35357/v2.0 token-get

If step2 doesn't work then you don't have role association between the user and the tenant. Use kesytone user-role-add to add the role to the tenant. Once you have added the role, it will work. You can get the list of available roles from keystone role-list

edit flag offensive delete link more

Comments

Thank you Haneef for your answer. I tried to authenticate without os-tenant-name parameter by requesting

keystone --os-username=admin --os-password=ADMIN_PASS --os-auth-url=http://controller:35357/v2.0 token-get

but i have de same message in my log file "keystone.common.wsgi [-] ...". When i tried to add the role to the tenant by requesting keystone user-role-add --user=admin --tenant=admin --role=admin i have this message: " Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL] "

Medou gravatar imageMedou ( 2014-06-20 10:44:57 -0500 )edit

It looks like sql connection error from your logs.

2014-06-19 20:28:04.306 16464 CRITICAL keystone [-] (OperationalError) (1045, "Access denied for user 'admin'@'localhost' (using password: YES)") None None

If that looks ok, then add debug = True in /etc/keytone/keystone.conf and restart keystone and check/post the logs

Can you check whether you able to access sql from keystone node?

Haneef Ali gravatar imageHaneef Ali ( 2014-06-20 11:27:09 -0500 )edit

Thank you Haneef, you were right, keystone node were not able to access sql. Finaly, i reconfigured keystone and it is ok now. Thank you once again.

Medou gravatar imageMedou ( 2014-06-20 13:10:14 -0500 )edit
0

answered 2014-06-20 04:29:54 -0500

Medou gravatar image

Thank you Haneef for your answer. I tried to authenticate without os-tenant-name parameter by requesting

keystone --os-username=admin --os-password=ADMIN_PASS --os-auth-url=http://controller:35357/v2.0 token-get

but i have de same message in my log file "keystone.common.wsgi [-] ...". When i tried to add the role to the tenant by requesting keystone user-role-add --user=admin --tenant=admin --role=admin i have this message: " Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL] "

edit flag offensive delete link more

Comments

can you show logs with error.

SGPJ gravatar imageSGPJ ( 2014-06-20 04:36:03 -0500 )edit

Thx Shankar, here is the link of my log file http://xbmclogs.com/show.php?id=230938

Medou gravatar imageMedou ( 2014-06-20 10:42:07 -0500 )edit

òk let me analyze.

SGPJ gravatar imageSGPJ ( 2014-06-21 14:05:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-19 12:05:57 -0500

Seen: 1,799 times

Last updated: Jun 20 '14