Ask Your Question

DHCP-agent AND L3-AGENT Bug in the guide?

asked 2014-06-19 10:25:21 -0500

New-stack gravatar image

updated 2014-06-19 10:55:18 -0500

hi peope,

i link this two pages:



In the first, i read that dhcp-agent and the l3-agent must (or can) run on the same node

In the second page, i read that if the dhcp-agent and the l3-agent runs on the same machines, maybe generate a overlapping of ip andress and however is necessary or use the namespace or split this two agents!

I follow the installation guide and now my problem is that the network is down!

Why this difference?

edit retag flag offensive close merge delete


Then with this kernel

uname --kernel-release 2.6.32-431.11.2.el6.x86_64

i need to upgrade at 2.6.32-*.openstack.el6.x86_64 to support the namespace?

New-stack gravatar imageNew-stack ( 2014-06-20 04:53:57 -0500 )edit

What version of CentOS are you running ? If 6.5 then NO. if 6.4 then YES.

dbaxps gravatar imagedbaxps ( 2014-06-20 05:03:14 -0500 )edit

2 answers

Sort by » oldest newest most voted

answered 2014-06-19 10:49:01 -0500

dbaxps gravatar image

dhcp-agent and the l3-agent may run on same box with no problems. In general, Neutron Server and all it's agents run on same node.

edit flag offensive delete link more



This is true only if the namespace is enabled! Otherwise, if one follow the installation guide, there are some conflict...

New-stack gravatar imageNew-stack ( 2014-06-19 10:53:56 -0500 )edit

You intend to use kernel with no namespaces support ? ;)

dbaxps gravatar imagedbaxps ( 2014-06-19 10:57:16 -0500 )edit


I had use a Linux version 2.6.32 and this version should have the namespaces support...but when i installed (following the guide) the neutron module, my network is crashed! And my first question is..WTF? :)

New-stack gravatar imageNew-stack ( 2014-06-19 11:09:33 -0500 )edit

answered 2014-06-25 06:45:21 -0500

New-stack gravatar image

the solution about this problem i found in the FAQ openswitch Post it...

Q: I created a bridge and added my Ethernet port to it, using commands like these:

   ovs-vsctl add-br br0
   ovs-vsctl add-port br0 eth0

and as soon as I ran the "add-port" command I lost all connectivity through eth0. Help!

A: A physical Ethernet device that is part of an Open vSwitch bridge should not have an IP address. If one does, then that IP address will not be fully functional.

You can restore functionality by moving the IP address to an Open vSwitch "internal" device, such as the network device named after the bridge itself. For example, assuming that eth0's IP address is, you could run the commands below to fix up the situation:

   ifconfig eth0
   ifconfig br0

(If your only connection to the machine running OVS is through the IP address in question, then you would want to run all of these commands on a single command line, or put them into a script.) If there were any additional routes assigned to eth0, then you would also want to use commands to adjust these routes to go through br0.

If you use DHCP to obtain an IP address, then you should kill the DHCP client that was listening on the physical Ethernet interface (e.g. eth0) and start one listening on the internal interface (e.g. br0). You might still need to manually clear the IP address from the physical interface (e.g. with "ifconfig eth0").

There is no compelling reason why Open vSwitch must work this way. However, this is the way that the Linux kernel bridge module has always worked, so it's a model that those accustomed to Linux bridging are already used to. Also, the model that most people expect is not implementable without kernel changes on all the versions of Linux that Open vSwitch supports.

By the way, this issue is not specific to physical Ethernet devices. It applies to all network devices except Open vswitch "internal" devices.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-06-19 10:25:21 -0500

Seen: 187 times

Last updated: Jun 25 '14