Ask Your Question
2

Connection to neutron failed:[Errno 11] Connection refused

asked 2014-06-19 09:48:25 -0500

Nouamn gravatar image

updated 2014-06-23 10:41:04 -0500

smaffulli gravatar image

I followed official guide for installing openstack ICEHOUSE on ubunto. Every thing was going fine until I reached networking section. I configured all of the settings for three nodes [networking , compute, controller].When I reached part to create Initial networks ==>external networks. I typed the command for the external network I got error Connection to neutron failed:[Errno 11] Connection refused

Now i know it has been asked many times and the typical solution is password for rabbitmq. But I can assure you that my settings are correct I have done settings three times. But i am facing the same problem. I have read all the answers but no luck do far.

My neutron server log file is empty. Neutron is running perfectly fine. log file for rbbitmq does not have any errors. FYI command is

neutron net-create ext-net --shared --router:external=True

Critical issues in debug info

DEBUG: neutronclient.client throwing ConnectionFailed : [Errno 111] Connection refused
ERROR: neutronclient.shell Connection to neutron failed: [Errno 111] Connection refused
  File "/usr/local/lib/python2.7/dist-packages/neutronclient/client.py", line 154, in _cs_request
    raise exceptions.ConnectionFailed(reason=e)
ConnectionFailed: Connection to neutron failed: [Errno 111] Connection refused
DEBUG: neutronclient.shell clean_up CreateNetwork
DEBUG: neutronclient.shell Got an error: Connection to neutron failed: [Errno 111] Connection refused

Other debugging info:

neutron agent-list ==> connection to neutron failed maximum attempts reached

netstat -lnpt | grep 9696 ==> No output

ps -ef | grep 5249 => root 20407 3185 0 10:22 tty1 00:00:00 frep --color=auto 5249

service neutron-server status => neutron-server start/pre-start, process 4865

iptables-save | grep 9696 => no output

edit retag flag offensive close merge delete

Comments

please show debug information

neutron --debug net-create ext-net --shared --router:external=True
Lawrence Lo gravatar imageLawrence Lo ( 2014-06-19 10:43:30 -0500 )edit

I'll be brutal and delete comments that contain more than 250 chars. Please edit your questions and provide answers. Comments are for small comments only, not to host debug info. https://ask.openstack.org/faq

smaffulli gravatar imagesmaffulli ( 2014-06-20 16:14:07 -0500 )edit

Thank you for your reply. I only posted debug information because @Lawerenc Lo asked it. To answer your question search for similar question. I did that. I have told you I did my homework but no luck. Other people solution was typical like password mismatch etc.

Nouamn gravatar imageNouamn ( 2014-06-22 23:44:55 -0500 )edit

@Nouamn What I mean is that you should edit your question and add details there, not add debug info to the comments.

smaffulli gravatar imagesmaffulli ( 2014-06-23 10:57:33 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-06-19 10:42:08 -0500

dbaxps gravatar image

updated 2014-06-23 10:54:55 -0500

smaffulli gravatar image

Some suggestions to debug this issue. On the node where you're running Neutron server

Check that the agent is running:

$ neutron agent-list

Make sure that Neutron's default TCP port 9696 is open and in LISTEN state:

[root@icehouse1 ~(keystone_admin)]#  netstat -lnpt | grep 9696
tcp        0      0 0.0.0.0:9696            0.0.0.0:*               LISTEN      5249/python

Check that the server is actually running and find out its pid:

$ service neutron-server status
 neutron-server start/pre-start, process ($PID_NUMBER)

[root@icehouse1 ~(keystone_admin)]# ps -ef | grep ($PID_NUMBER)
root      1796  4639  0 19:41 pts/0    00:00:00 grep --color=auto 5249
neutron   5249     1  0 05:35 ?        00:02:27 /usr/bin/python /usr/bin/neutron-server --config-file  /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log

Double check that the server is indeed running:

 $ ps -ef | grep neutron-server

Check the config files and make sure that Neutron is using port 9696 (or find out which port it's configured to use in your case).

Make sure that there are no firewall rules preventing connection to Neutron's port. For example:

$ sudo iptables -L | grep 9696

(or whatever port number Neutron is running on).

edit flag offensive delete link more

Comments

sorry, but I am getting no output form these two commands netstat -lnpt | grep 9696 iptables-save | grep 9696

Nouamn gravatar imageNouamn ( 2014-06-23 02:00:55 -0500 )edit

OPEN PORT 9696 ( IF NEUTRON SERVER IS UP AND RUNNING )

dbaxps gravatar imagedbaxps ( 2014-06-23 03:56:06 -0500 )edit

opened the port with iptables -A INPUT -p tcp --dport 9696 -j ACCEPT still no output from above mentioned commands

Nouamn gravatar imageNouamn ( 2014-06-23 08:36:02 -0500 )edit

$ ps -ef | grep neutron-server - on Neutron Node.

dbaxps gravatar imagedbaxps ( 2014-06-23 09:25:26 -0500 )edit

@dbaxps I've edited your answer to include the suggestions you're giving in comments. I'd like to make this question more of a guide to debug Neutron's issues, with your help.

smaffulli gravatar imagesmaffulli ( 2014-06-23 10:56:19 -0500 )edit
2

answered 2014-06-24 02:43:18 -0500

Nouamn gravatar image

updated 2014-06-24 02:47:22 -0500

After 3,4 days of debugging I finally solved the issue. Solution => If you are following official guide, on controller node open file /etc/neutron/neutron.conf file go to section [keystone_authtoken] and comment out the line signing_dir = $state_path/keystone-signing or give the directory rights. Pleas mentioned this in the guide.

Thank you all who helped me in solving this issue.

edit flag offensive delete link more

Comments

Sidenote: In Openstack Juno, there's no such line in the same section of the same file.

Luigi gravatar imageLuigi ( 2015-09-04 07:59:49 -0500 )edit
0

answered 2016-12-12 11:13:21 -0500

Rupesh Chowdary gravatar image

Check the openstack commands are running or not. Try to check nova commands.

  1. Verify the port is open or not. If firewall blocking the port use the following to open the port,

    iptables -A INPUT -p tcp --dport 9696 -j ACCEPT

  2. Also check the following commands,

$neutron agent-list $netstat -lnpt | grep 9696

  1. If all the above is fine then restart the neutron service and try to check the network creation,

$ service neutron-server restart

  1. Try to create new network,

$openstack --debug network create test01

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-19 09:48:25 -0500

Seen: 9,033 times

Last updated: Dec 12 '16