Ask Your Question
0

Instances dnsdomainname not set

asked 2014-06-18 05:33:53 -0500

anonymous user

Anonymous

updated 2014-06-18 05:35:45 -0500

I have set up an Openstack Environment (Icehouse Release) on Ubuntu 14.04 LTS Hosts as described in the http://docs.openstack.org/icehouse/install-guide/install/apt/content/ (Installation Guide) with Neutron (ML2 Plugin) networking.

Although I have set

dhcp_domain = my.desired.domain

in /etc/neutron/dhcp_agent.ini on my network node and packet-capturing with wireshark on this host tells me the DHCP-Offer and DHCP-Ack Messages contain the correct domain name, this domain name isn't set within the new spawned instance. hostname -f tells me hostname: Name or service not known and /etc/hosts only contains this one line

127.0.0.1 localhost

Web-searches didn't bring any results, is this a known bug of neutron or nova, or did i just miss anything in my configs?

thx for any help!

edit retag flag offensive close merge delete

Comments

If you can run curl http://169.254.169.254/latest/meta-data/ from within VM, then update private network of your VMs with real DNS IP-address of your ISP.

For instance :-
# INT_SUBNET_ID=`neutron subnet-list | grep your_private_subnet | awk '{ print $2}'`
# neutron subnet-update $INT_SUBNET_ID --dns_nameservers list=true 83.221.202.254
dbaxps gravatar imagedbaxps ( 2014-06-18 06:09:39 -0500 )edit

curl http://169.254.169.254/latest/meta-data/hostname answeres with <instance_name>.<dhcp_domain> as i suppose it should do. DNS Servers (same ip addresses as used in the company network) are already set for my tenants private network and working for nslookup calls on any external domain names

MarcS gravatar imageMarcS ( 2014-06-18 06:36:06 -0500 )edit

OK. Run curl http://msn.com if it works install links and try to launch it to msn.com

dbaxps gravatar imagedbaxps ( 2014-06-18 06:43:41 -0500 )edit

the curl call answeres with a "document moved" html document, after installing and configuring proxy-settings for companys http proxy the links call works correctly

MarcS gravatar imageMarcS ( 2014-06-18 07:00:02 -0500 )edit

Then assign floating IP and update /etc/hosts correspondently
floating-ip fqdn

dbaxps gravatar imagedbaxps ( 2014-06-18 07:46:03 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-18 11:38:49 -0500

MarcS gravatar image

UPDATE:

I found out, that the following entry in the user-data section solves my problem:

#cloud-config
manage_etc_hosts: true

Instances bootet with this user-data entry will have a /etc/hosts file matching the corresponding template in the Instance Image. Possible workarounds would therefore be to provide that user-data to every instance wich is bootet, or to modify all my Cloud-Images to have manage_etc_hosts: true in their /etc/cloud/cloud.cfg

Is there any possibility to tell cloud-init to use this as default setting?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-18 05:33:53 -0500

Seen: 1,989 times

Last updated: Jun 18 '14