Heat Autoscaling Template with Neutron failed [closed]

asked 2014-06-18 00:16:18 -0600

updated 2014-06-20 16:36:07 -0600

smaffulli gravatar image

I have a working OpenStack installation on a single server based on instructions at ITINSTEPS.

I have added the following rule in iptables for Heat:

 -A INPUT -p tcp -m multiport --dports 8000,8003,8004 -m comment --comment "001 heat-api incoming ALL" -j ACCEPT

I have a modified Heat Autoscaling Template for Neutron that I am trying to provision ( https://drive.google.com/file/d/0BzdC... ).

I am using the image Fedora-x86_64-20-20140407-sda.qcow2 (which is supposed to have cfntools installed).

After I launch the stack, I get the following error in the /var/log/heat/heat-engine.log:

***2014-06-18 10:35:29.355 3401 TRACE heat.engine.resource Error: neutron reported unexpected vip resource[pool.vip] status[ERROR]***
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by KunalTPatil
close date 2014-06-23 03:27:28.359908

Comments

The virtual IP is in an ERROR state. You'll want to check the Neutron log to find out why.

zaneb gravatar imagezaneb ( 2014-06-19 15:33:27 -0600 )edit

You were right. I guess my configuration of the LBAAS is wrong somewhere. The error in server.log in neutron was:

Create vip 5764c0fb-4850-43bf-9729-f622e74ff95e failed on device driver haproxy_ns

KunalTPatil gravatar imageKunalTPatil ( 2014-06-21 23:11:43 -0600 )edit

Really silly. While enabling LBAAS, I skipped the part where I needed to install haproxy. Its working fine now.

KunalTPatil gravatar imageKunalTPatil ( 2014-06-21 23:44:05 -0600 )edit