how to disable the -boot strict=on for qemu

asked 2014-06-17 11:29:12 -0500

RonR gravatar image

We are running with icehouse on ubuntu 14.04 and want to have a vm do a network boot; however, qemu is always started with the -boot strict=on which seems to prevent it from trying network devices after trying to boot off of disk. The -boot strict=on does not show up on a system with Redhat 6.5/Icehouse.

edit retag flag offensive close merge delete

Comments

I have a hack that changes the default behavior of libvirt to append -boot strict=on that is added to argument of the qemu call. The proper way to fix this would be to do changes in Nova to add the properly XML template items for boot order.

elopez gravatar imageelopez ( 2015-02-25 16:05:29 -0500 )edit