Ask Your Question
0

glance error : Requested version of OpenStack Images API is notavailable

asked 2013-07-19 13:31:42 -0500

krishnaprasad gravatar image

updated 2013-07-22 14:26:11 -0500

smaffulli gravatar image

I use the below glance RPM versions.

openstack-glance-2013.1.2-1.fc19.noarch
python-glanceclient-0.9.0-2.fc19.noarch
python-glance-2013.1.2-1.fc19.noarch

installed from Fedora-18 repo.

 [fedora-openstack-grizzly] 
 name=OpenStack Grizzly Repository for Fedora 
 baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/fedora-$releasever/ 
 enabled=1 
 skip_if_unavailable=1 
 gpgcheck=0

The glance image-list command shows the below error. what could be the reason ?

~# glance image-list 
 HTTPMultipleChoices (HTTP 300) Requested version of OpenStack Images API is notavailable.

The default installation sets enable_v2_api set to 'True' and enable_v1_api set to 'false'. When v1 is set to enabled and v2 set to disabled, this error is not seen. Is this an expected behavior ?

edit retag flag offensive close merge delete

Comments

how did you install glance service? please provide more details about the host you're trying to get image-list from

smaffulli gravatar imagesmaffulli ( 2013-07-19 16:08:57 -0500 )edit

I use Fedora-18. Also I used the fedora repo. [fedora-openstack-grizzly] name=OpenStack Grizzly Repository for Fedora baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/fedora-$releasever/ enabled=1 skip_if_unavailable=1 gpgcheck=0

krishnaprasad gravatar imagekrishnaprasad ( 2013-07-20 01:41:32 -0500 )edit

To be specific, here is the repo used http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/fedora-18/%3C/p%3E (http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/fedora-18/)

krishnaprasad gravatar imagekrishnaprasad ( 2013-07-20 01:43:17 -0500 )edit

you can amend your answer instead of adding comments :)

smaffulli gravatar imagesmaffulli ( 2013-07-22 14:19:28 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-07-22 14:21:56 -0500

smaffulli gravatar image

Taking from $ glance --help

  --os-image-api-version OS_IMAGE_API_VERSION
                    Defaults to env[OS_IMAGE_API_VERSION] or 1

if you have not specified the OS_IMAGE_API_VERSION variable then probably your client is defaulting to use API v1 and your service doesn't have that version enabled.

edit flag offensive delete link more

Comments

Thanks for all the help :)

krishnaprasad gravatar imagekrishnaprasad ( 2013-07-22 23:16:11 -0500 )edit
0

answered 2013-07-22 00:49:02 -0500

krishnaprasad gravatar image

The error was due to enable_v2_api set to 'True' and enable_v1_api set to 'false'. When v1 is set to enabled and v2 set to disabled, this error is not seen. Is this an expected behavior ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-19 13:31:42 -0500

Seen: 1,288 times

Last updated: Jul 22 '13