Ask Your Question
0

IP is not getting assigned to OpenStack VM instance interface

asked 2014-06-17 04:14:39 -0600

Priya gravatar image

Issue : IP is not getting assigned to OpenStack VM instance interface

Openstack deployment detail : Multinode setup(Openstack networking) which includes a controller, neutron and a compute node using OVS and GRE overlay

System Configuration: (Controller Node, Neutron Node and Compute Node)

OS : Ubuntu Kernel Release : 14.04 Processor : x86_64 OVS Version : 2.0.1

Openstack Version details:

Controller node - icehouse Release, installed using apt-get Neutron node - icehouse Release, installed using devstack Compute node - icehouse Release, installed using apt-get

Issue Description:

We were able to launch the VM instance successfully via OpenStack horizon. From the horizon, we could see the IP is getting allocated for the VM. But the IP is not getting assigned to the VM's interface.

We noticed that the GRE tunnel is established successfully and the VM instance is also sending DHCP discover over the established tunnel. The following are some of the debugging steps that we carried out.

Debug Step - 1 :

After launching VM, the "virsh-list" command was executed in the compute node

root@compute11:~# virsh list

Id Name State

2 instance-0000001b running

3 instance-0000001a running

4 instance-0000001c running

Debug Step - 2 :

In the neutron node, we noticed that the namespace has been created for the instance network. root@neutron:~# ip netns qdhcp-3a40b173-1c9b-438a-bf02-bdb00c09c724

Also verified if the TAP interface for the namespace is created.

root@neutron:~# ip netns exec qdhcp-3a40b173-1c9b-438a-bf02-bdb00c09c724 ifconfig lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

tap33bc68c4-18 Link encap:Ethernet HWaddr fa:16:3e:9e:7a:26
inet addr:182.0.0.2 Bcast:182.0.0.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe9e:7a26/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:74 errors:0 dropped:0 overruns:0 frame:0 TX packets:11 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:6212 (6.2 KB) TX bytes:906 (906.0 B) Note: We got the IP for VM's interface one time and we could not reproduce this behaviour subsequently.

Debug Step- 3 :

While issuing the command "neutron agent-list", we found that the agent's "alive" status is toggling between ":-)" and "xxx".

root@neutron:~# neutron agent-list Starting new HTTP connection (1): 192.168.66.61 Starting new HTTP connection (1): controller +--------------------------------------+--------------------+-----------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+-----------+-------+----------------+ | 01745df9-f0d2-43df-a8e3-ff55bdf88b37 | Open vSwitch agent | neutron | :-) | True | | 30c10a47-9237-4f7a-9111-f78285ab9ff9 | Metadata agent | neutron | :-) | True | | 878206c1-011c-4501-893d-447db9b683cb | Metering agent | neutron | xxx | True | | c8f12c3c-8cc6-4fbe-acf3-62caed95e834 | L3 agent | neutron | :-) | True | | e1712b4d-2ca6-49a5-8dab-072441b4af80 | DHCP agent | neutron | xxx | True | | e6da27ae-f866-4653-ada6-04a89b801291 | Open vSwitch agent | compute11 | xxx | True | +--------------------------------------+--------------------+-----------+-------+----------------+

As a work around, we have updated the following values in /etc/neutron/neutron.conf file and restarted all nodes services.

[DEFAULT]

agent_down_time = 90

[agent]

report_interval ... (more)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-18 09:08:31 -0600

Priya gravatar image

Hi,

Thanks for your reply. :) From your reply, i understand that you have got DHCP discover messages on executing "ip netns exec qdhcp-xxx tcpdump ".

But our issue is that "We saw the discover message in br-tun bridge and not in the br-int bridge at the neutron node" and so we didnot receive any packets on executing "ip netns exec qdhcp-xxx tcpdump ".Also the agent-list's status gets toggled.

Today we re-installed OVS and restarted all the services at controller,neutron and compute node. Now IP is getting assigned to VM and we can ping from the VM's console to its gateway. Toggling of agent-list still happens but at a rare case.

edit flag offensive delete link more

Comments

Hi Hari, Thanks for the reply. The problem was with NTP synchronization. Since the compute and neutron node's time was far ahead than that of the controller node,the issue had occured.

Once NTP was properly synchronized, the issue was solved.

Priya gravatar imagePriya ( 2014-11-12 05:35:51 -0600 )edit
0

answered 2014-10-27 00:46:29 -0600

Hari gravatar image

Try making up and down the bridge and interface associated to it. It worked for me.

ifdown br-ex ; ifup br-ex
ifdown eth2 ; ifup eth2
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-17 04:14:39 -0600

Seen: 7,316 times

Last updated: Oct 27 '14