Ask Your Question
1

neutron problem

asked 2014-06-16 13:31:02 -0500

lee yong goon gravatar image

updated 2014-06-16 14:40:34 -0500

smaffulli gravatar image

Installing OpenStack version Havana on ubuntu 12.04 LTS. My openrc.sh file value.

export OS_USERNAME=admin
export OS_PASSWORD=e1f9978beb38aac8c2a7
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://controller:35357/v2.0
export SERVICE_ENDPOINT=http://controller:5000/v2.0/
export SERVICE_TOKEN=admin

Command Error

$ keystone user-list
WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).
The resource could not be found. (HTTP 404)

OVS problem

Gre tunnel between network node and compute node not generated.

/var/log/neutron/server.log

2014-06-17 02:52:42.068 2667 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver
2014-06-17 02:52:42.319 2667 WARNING neutron.api.extensions [-] Extension router-service-type not supported by any of loaded plugins
2014-06-17 02:52:42.322 2667 WARNING neutron.api.extensions [-] Extension metering not supported by any of loaded plugins
2014-06-17 02:52:42.324 2667 WARNING neutron.api.extensions [-] Extension fwaas not supported by any of loaded plugins
2014-06-17 02:52:42.325 2667 WARNING neutron.api.extensions [-] Extension vpnaas not supported by any of loaded plugins
2014-06-17 02:52:42.326 2667 WARNING neutron.api.extensions [-] Extension routed-service-insertion not supported by any of loaded plugins
2014-06-17 02:52:42.326 2667 WARNING neutron.api.extensions [-] Extension service-type not supported by any of loaded plugins
2014-06-17 02:52:42.327 2667 WARNING neutron.api.extensions [-] Extension multi-provider not supported by any of loaded plugins
2014-06-17 02:52:42.328 2667 WARNING neutron.api.extensions [-] Extension lbaas not supported by any of loaded plugins
2014-06-17 02:52:42.329 2667 WARNING neutron.api.extensions [-] Extension lbaas_agent_scheduler not supported by any of loaded plugins
2014-06-17 02:52:42.330 2667 WARNING neutron.api.extensions [-] Extension port-security not supported by any of loaded plugins
2014-06-17 02:52:42.331 2667 WARNING neutron.api.extensions [-] Extension flavor not supported by any of loaded plugins
2014-06-17 02:52:42.346 2667 WARNING keystoneclient.middleware.auth_token [-] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-06-16 22:56:17 -0500

tahder gravatar image

updated 2014-06-16 22:59:12 -0500

Are you behind proxy server? else try to add in your script, as it sometimes generate error similar to what i encountered based on my experience.

export no_proxy="localhost,127.0.0.0.1,controller"
#and 
export OS_USERNAME=admin
export OS_PASSWORD=e1f9978beb38aac8c2a7
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://controller:5000/v2.0

no need to add the SERVICE_ENDPOINT nor SERVICE_TOKEN try to unset it. As they are keystone specific command (correct me if i am wrong), unless you do it from scratch meaning creating users, tenants et al, at the starting point but if already define then you have to unset it.

unset SERVICE_ENDPOINT
unset SERVICE_TOKEN
edit flag offensive delete link more
0

answered 2014-06-16 13:45:47 -0500

updated 2014-06-16 21:19:06 -0500

What is your keystone auth url? Keystone listens at 2 ports in v2.0. One is 35357 and other is 5000. Change your auth url to use admin port which is 35357. Most probably you are using port 5000

Update-1

No, you don't need to change in all the other configurations. 5000 ports allows only token operation and couple more api calls, whereas 35357 allows everything. All the other services just need token operation.

You need to change the port to 35357 only for keystone client. (ie) keystone user-list etc needs port 35357.

User keystone --debug user-list . This gives you the url that keystone client is using to talk to the server

Update-2

In your debug log, it uses port 5000 which is the source of problem Either unset SERVICE_ENDPOINT or export SERVICE_ENDPOINT=http://controller:35357/v2.0/

edit flag offensive delete link more

Comments

Change of the values ​​in the all config file do I need? 5000 → 35357??? openrc.sh → 5000 → 35357???

lee yong goon gravatar imagelee yong goon ( 2014-06-16 13:49:28 -0500 )edit

export OS_USERNAME=admin

export OS_PASSWORD=e1f9978beb38aac8c2a7

export OS_TENANT_NAME=admin

export OS_AUTH_URL=http://controller:35357/v2.0

export SERVICE_ENDPOINT=http://controller:5000/v2.0/

export SERVICE_TOKEN=admin

My openrc.sh file value. Wrong?

lee yong goon gravatar imagelee yong goon ( 2014-06-16 13:50:43 -0500 )edit

Please edit the question itself to add more information

Haneef Ali gravatar imageHaneef Ali ( 2014-06-16 14:16:39 -0500 )edit

keystone --debug user-list

WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).

REQ: curl -i -X GET http://controller:5000/v2.0/users -H "User-Agent: python-keystoneclient" -H "X-Auth-Token: admin"

RESP: [404] CaseInsensitiveDict({'date': 'Tue, 17 Jun 2014 00:33:14 GMT', 'vary': 'X-Auth-Token', 'content-length': '93', 'content-type': 'application/json'})

RESP BODY: {"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}

Please help me!!

lee yong goon gravatar imagelee yong goon ( 2014-06-16 19:35:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-16 13:31:02 -0500

Seen: 1,200 times

Last updated: Jun 16 '14