Setting http_proxy causes Services to become unavailable

asked 2014-06-16 07:49:12 -0600

stdg11 gravatar image

Hi Guys,

I've been trying to figure out why I cant add images to Glance from an external URL. In the api.log I notice it says:

Copy From external source failed: [Errno 101] ENETUNREACH

Then I tried downloading the image using curl

root@brgracloud:/tmp#  curl -X HEAD -vvv
* Hostname was NOT found in DNS cache
*   Trying
*   Trying 2001:67c:1360:8c01::1e...
* Immediate connect fail for 2001:67c:1360:8c01::1e: Network is unreachable

We are sat behind a proxy (thankfully thats changing in a couple of months!).So I set the http_proxy,https_proxy and ftp_proxy in roots .profile. Im not sure if this is the correct way of setting the proxy address for OpenStack to use.

Once these variables are set however this presents a new problem whereby running any command e.g. Nova list, Keystone user-list Glance image-list it returns.

Authorization Failed: Service Unavailable (HTTP 503)

Then curl will successfully download, but obviously I can use any OpenStack services.

I've been scratching my head all morning and have reached a stalemate. Have i set the proxy wrong? Do you need anymore Info?

Any help you could offer would be greatly appreciated! :)

edit retag flag offensive close merge delete


After setting the no_proxy environment variable I can curl and still use various services. However running a glance image-create --copy-from still returns:

Copy From external source failed: [Errno 101] ENETUNREACH
stdg11 gravatar imagestdg11 ( 2014-06-16 10:16:12 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2014-06-16 13:24:28 -0600

I believe you are out of luck. All the other clients uses Request library for HTTP which supports proxy settings from environment . Glance use different library

edit flag offensive delete link more


Thanks for the reply Haneef, Surely someone uses glance behind a proxy somewhere? Is the only way to proceed with this for users to request an image and then I add it manually.

stdg11 gravatar imagestdg11 ( 2014-06-16 13:30:29 -0600 )edit

answered 2014-06-18 19:02:54 -0600

ArunKant gravatar image

You may follow the open bug around this..

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2014-06-16 07:49:12 -0600

Seen: 1,445 times

Last updated: Jun 18 '14