Metadata service not working in multi node. [closed]

asked 2014-06-16 05:40:01 -0600

Deeptanshu gravatar image

updated 2014-06-16 06:39:19 -0600

Hi,

After long search and discussion i am still unable to find the answer of the below error. I would like to introduce my setup first.I have installed all the services on ubuntu 12.04 LTS. I have configured Icehouse with multinode compute. I am using Neutron as a network service . All the services are working fine and i am able to launch the instance too. Dhcp is working fine and instance are able to connect each other. But when i tried to access the instance with public Key it end up with no result. When i checked the logs i came to know there is some issue with the meta services.

I have configure the new setup again on icehouse but still the error is same.

I have followed the Openstack official docs for the installation. Do i require any special settings for meta data service in multi node.

http://docs.openstack.org/icehouse/in...

Please suggest the solution.


With Centos Image i am getting below error.

Could not retrieve public key from instance metadata (attempt #1/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #2/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #3/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #4/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #5/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #6/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #7/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #8/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #9/30), retrying in 5 seconds...

Could not retrieve public key from instance metadata (attempt #10/30), retrying in 5 seconds...


cirros-ds 'net' up at 6.60

checking http://169.254.169.254/2009-04-04/ins...

failed 1/20: up 6.90. request failed

failed 2/20: up 19.23. request failed

failed 3/20: up 31.42. request failed

failed 4/20: up 43.62. request failed

failed 5/20: up 55.83. request failed

failed 6/20: up 68.03. request failed

failed 7/20: up 80.22. request failed

failed 19/20: up 226.88. request failed

failed 20/20: up 239.11. request failed

failed to read iid from metadata. tried 20

no results found for mode=net. up 251.33. searched: nocloud configdrive ec2

failed to get instance-id of datasource

Starting dropbear sshd: OK

=== system information ===

Platform: OpenStack Foundation OpenStack Nov

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2015-11-16 15:42:19.501928

Comments

Post ls -l under /etc/neutron on NeutronServer && Compute Node.

dbaxps gravatar imagedbaxps ( 2014-06-16 06:23:29 -0600 )edit

Hi,

Find the require details below.

On Compute

root@compute:/etc/neutron# ls -l

total 56

-rw-r--r-- 1 root neutron 1017 Apr 17 17:20 api-paste.ini

-rw-r--r-- 1 root neutron 109 Apr 17 17:20 fwaas_driver.ini

-rw-r--r-- 1 root neutron 3108 May 20 17:35 l3_agent.ini

-rw-r--r-- 1 root neutron 17763 Jun 10 12:45 neutron.conf

drwxr-xr-x 3 root neutron 4096 May 19 18:45 plugins

-rw-r--r-- 1 root neutron 6148 Apr 17 17:20 policy.json

-rw-r--r-- 1 root root 1216 Apr 17 17:20 rootwrap.conf

drwxr-xr-x 2 root root 4096 May 19 18:45 rootwrap.d

-rw-r--r-- 1 root neutron 526 Apr 17 17:20 vpn_agent.ini


On neutron

root@network:/etc/neutron# ls -l

total 64

-rw-r--r-- 1 root neutron 1017 Apr 17 17:20 api-paste.ini

-rw-r--r-- 1 root neutron 3555 Jun 5 17:44 dhcp_agent.ini

-rw-r--r-- 1 root neutron ...

(more)
Deeptanshu gravatar imageDeeptanshu ( 2014-06-16 06:36:04 -0600 )edit

As far as I remember it's Neutron ML2&OVS&GRE setup :-

[root@icehouse1 neutron(keystone_admin)]# ls  -l
total 88
-rw-r--r--. 1 root root      193 Jun 13 05:19 api-paste.ini
-rw-r-----. 1 root neutron  3902 Jun 13 08:31 dhcp_agent.ini
-rw-r--r--. 1 root root       73 Jun 13 08:32 dnsmasq.conf
-rw-r-----. 1 root neutron   109 Apr 17 15:50 fwaas_driver.ini
-rw-r-----. 1 root neutron  3431 Jun 13 05:19 l3_agent.ini
-rw-r-----. 1 root neutron  1400 Apr 17 15:50 lbaas_agent.ini
-rw-r-----. 1 root neutron  1481 Jun 13 07:52 metadata_agent.ini
lrwxrwxrwx. 1 root root       37 Jun 13 06:42 ml2_conf.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
-rw-r-----. 1 root neutron 19089 Jun 13 06:03 neutron.conf
-rw-r--r--. 1 root root     1675 Jun 14 20:04 neutron.sample
-rw-r--r--. 1 root root     1583 Jun 13 09:24 ovs-vsctl.out
lrwxrwxrwx. 1 root ...
(more)
dbaxps gravatar imagedbaxps ( 2014-06-16 06:41:04 -0600 )edit

Snapshot has been done on (Controller+NeutronServer)+Compute system. Currently up and running on Fedora 20 hosts with no problems with metadata access from within VMs

dbaxps gravatar imagedbaxps ( 2014-06-16 06:44:37 -0600 )edit

Hi,

Yes i have configured ML2&OVS&GRE setup .It was working fine on Havana. Now i dnt know where i am lacking.

Is there any addition setting require with multinode?

http://docs.openstack.org/admin-guide...

Deeptanshu gravatar imageDeeptanshu ( 2014-06-16 06:45:40 -0600 )edit