Ask Your Question
0

install lbaas fwaas vpnaas on production neutron

asked 2014-06-16 03:21:55 -0500

atze.devries gravatar image

Hello,

I'm trying to add neutron services (lbaas, fwaas adn vpnaas) to our production neutron service (ofcourse first in a testing enviroment). When i try to install these services on a empty stack install all works fine. We are running havanna. But if i add these services after there is already some data in neutron stuff does not work. neutron-db-manage does not seem to add the nessesary tables to the neutron db.

Is this behaviour suppost to be like this? Or are we doing something work?

edit retag flag offensive close merge delete

Comments

Here is the guide I used to setup those on test environment: https://gist.github.com/cloudnull/885...

Alen Komljen gravatar imageAlen Komljen ( 2014-06-16 03:35:38 -0500 )edit

Yes i've followed all the guidelines but still no solution. The neutron-server service fails when the lbaas plugin is enables (cannot find neutron.pools mysql table). If i leave out lbaas, neutron-server starts but still some mysql tables are not created.

atze.devries gravatar imageatze.devries ( 2014-06-16 07:40:12 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-08-27 01:11:06 -0500

SGPJ gravatar image

After configuration, please restart the services and use.

edit flag offensive delete link more
1

answered 2014-08-01 07:48:13 -0500

Beny gravatar image

Hi,

I have followed this document http://docs.openstack.org/admin-guide... to enable the lbaas in neutron and it worked for me.

Please make sure to restart all nova and neutron services after the configuration.

Thanks!!

edit flag offensive delete link more
0

answered 2014-06-24 00:14:01 -0500

ed gravatar image

Same here, I have everything installed and configured (Ubuntu 14.04 with Icehouse) and cannot get it to work:

root@stack-controller:~# neutron vpn-ikepolicy-create ikepolicy1
404 Not Found

The resource could not be found.

root@stack-controller:~# neutron firewall-list
404 Not Found

The resource could not be found.
edit flag offensive delete link more

Comments

Ran into exact the same problem. Have you guys found a fix or workaround meanwhile? Error disapears, if I disable service_plugins = lbaas in neutron.conf. But then lbaas does not work, of course.

ICBeter gravatar imageICBeter ( 2014-07-29 06:03:19 -0500 )edit

I guess it should be service_plugins = router, lbaas, fwaas and it is working for me. make sure this service_plugins parameter is not repeated again.

Beny gravatar imageBeny ( 2014-09-25 01:57:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2014-06-16 03:21:55 -0500

Seen: 1,542 times

Last updated: Aug 27 '14