Ask Your Question
6

horizon session timeout

asked 2014-06-13 19:53:13 -0600

sameer gravatar image

updated 2014-06-13 19:54:17 -0600

Is there a way to disable horizon's session timeout completely? I'm running a dev/test openstack IceHouse on Ubuntu trusty 14.04 Thanks,

edit retag flag offensive close merge delete

Comments

Whats up with this did it work for someone ?

/T

trollkarlen gravatar imagetrollkarlen ( 2015-08-21 08:57:03 -0600 )edit
1

I have tested this in Juno as follows:

Add the below line to /etc/openstack-dashboard/local_settings.py

SESSION_TIMEOUT = <timeout_in_seconds>

service apache2 restart

Add the below line to /etc/keystone/keystone.conf

expiration=<timeout_in_seconds>

service keystone restart

b-koessler gravatar imageb-koessler ( 2015-10-22 11:13:46 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
6

answered 2014-06-13 22:42:46 -0600

david-lyle gravatar image

updated 2014-06-13 22:43:40 -0600

There is no way to disable the timeout, which defaults to 30 minutes. However, you can increase the timeout to a much longer interval by adding

SESSION_TIMEOUT = desired number of seconds

to your local_settings.py and restarting apache.

Keystone will still have a default token expiration duration that may be encountered.

edit flag offensive delete link more

Comments

That explains it then! Because I did set session_timeout to a large number yet the session was expiring. Must be the token expiry you mentioned. Thanks.

sameer gravatar imagesameer ( 2014-06-14 19:38:13 -0600 )edit

I have a similar issue. What is the default value for tokens? I see commented out "#expiration=3600" in my keystone.conf (so by default it's 1h) and I've already set SESSION_TIMEOUT in local_settings.py to same value, without success. It still expires in less than 10-15 mins.

semyazz gravatar imagesemyazz ( 2014-09-17 05:01:57 -0600 )edit

Have similar problem. Dashboard enforce to re-login very 10 mins around. I guess it's related with session_storage except session_timeout.

WangBo gravatar imageWangBo ( 2016-03-21 02:35:22 -0600 )edit

Hi All, Is there anything with the resolution of this error ?

elmopps gravatar imageelmopps ( 2016-12-05 21:31:49 -0600 )edit
0

answered 2015-12-21 20:51:53 -0600

kikas gravatar image

For newer versions of Openstack: The command to restart keystone is:

service openstack-keystone restart

The command to restart apache is:

service httpd restart
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-06-13 19:53:13 -0600

Seen: 13,301 times

Last updated: Jun 13 '14