glance image-create HTTP error 500 [closed]

asked 2014-06-13 06:32:17 -0500

petrolej gravatar image

updated 2014-06-13 07:40:08 -0500

Hello,

I am new to Openstack and I know that this has been solved multiple times here in forums but I am still not able to solve this error. I am trying to follow the Openstack installation guied on CentOS 6.5 64.bit and I am stuck in Verifying of the Image service installation.

This is what happens:

[root@controller ~]# glance image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
[=============================>] 100%
Request returned failure status.
HTTPInternalServerError (HTTP 500)

And this is in the registry log which I believe is the source of the error.
[root@controller ~]# tail /var/log/glance/registry.log
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/engine/strategies.py", line 80, in connect
    return dialect.connect(*cargs, **cparams)
  File "/usr/lib64/python2.6/site-packages/sqlalchemy/engine/default.py", line 283, in connect
    return self.dbapi.connect(*cargs, **cparams)
  File "/usr/lib64/python2.6/site-packages/MySQLdb/__init__.py", line 81, in Connect
    return Connection(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/MySQLdb/connections.py", line 187, in __init__
    super(Connection, self).__init__(*args, **kwargs2)
OperationalError: (OperationalError) (1045, "Access denied for user 'glance'@'controller' (using password: YES)") None None
2014-06-13 13:28:23.507 3072 INFO glance.wsgi.server [178205f0-32be-4b28-b114-8a2aaf00dfc5 9fd45bf1f9494aa09eb5a88f3428d99e 49b9193572464a569d9c772832fd58ad - - -] 127.0.0.1 - - [13/Jun/2014 13:28:23] "POST /images HTTP/1.1" 500 139 0.271863

But where should I check the password? I believe I have entered it correctly everywhere. I also have the source file loaded and I am able to get a token using the command "keystone token-get".

What am I doing wrong?

Thanks in advance.

Best regards Petr Olejník

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-17 07:12:11.037090

Comments

PLease run :- [root@icehouse1 ~(keystone_admin)]# mysql -u root -p Enter password: Welcome to the MariaDB monitor. Commands end with ; or \g. Your MariaDB connection id is 534 Server version: 5.5.36-MariaDB-wsrep MariaDB Server, wsrep_25.9.r3961

Copyright (c) 2000, 2014, Oracle, Monty Program Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>  SELECT User, Host, Password FROM mysql.user;
dbaxps gravatar imagedbaxps ( 2014-06-13 07:32:04 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2014-06-13 07:44:13 -0500

You've misconfigured Glance. Based on the logs, it seems that your database user glance has no password associated for the host controller. I'd recommend you to check your database settings and update your glance-api.conf / glance-registry.conf file with the correct info.

Check the database steps in this link

edit flag offensive delete link more

Comments

Thank you, flaper87. Once again the error was somewhere between chair and keyboard. Your link provides a little different steps then [here](http://docs.openstack.org/icehouse/install-guide/install/yum/content/glance-install.html), but you were right that I miconfigured the glance. I think I have omittted the "IDENTIFIED BY 'GLANCE_DBPASS'" in the MYSQL steps. Running them again solved the issue.

Thanks for a quick response.

BR Petr

petrolej gravatar imagepetrolej ( 2014-06-16 01:58:13 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-13 06:32:17 -0500

Seen: 4,215 times

Last updated: Jun 13 '14