Ask Your Question
0

Icehouse: installation keystone Unable to establish connection [closed]

asked 2014-06-11 00:39:45 -0500

Pradyumna gravatar image

Hello OpenStack community,

Im installing icehouse on CentOS. Everything looks good unti I come to this point.

# keystone user-create --name admin --pass xxx --email xxx@xxx 
Unable to establish connection to http://cinnamon:35357/v2.0/users

I have no clue why this seems to be happening. Here are the things Ive tried so far to debug this:

# telnet cinnamon 35357
Trying 170.95.204.3...
Connected to cinnamon.
Escape character is '^]'

So this probably means the port is open and working.

#mysql -u keystone -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 23
Server version: 5.1.73 Source distribution
....

Im not sure whats going on. Can you guys tell me a potential solution or atleast where to look to start debugging ? The logs of keystone and mysql dont seem to suggest anything wrong.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-17 07:49:41.928224

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-06-11 03:11:25 -0500

Pradyumna gravatar image

updated 2014-06-11 06:18:10 -0500

SOLVED:

The problem was that I had the http_proxy environment variable set. I then ran the keystone command line client with --debug and this what I saw.

# keystone --debug user-create --name admin --pass xxxx --email xxx@xxx
DEBUG:keystoneclient.session:REQ: curl -i -X POST http://cinnamon:35357/v2.0/users -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: xxxxx" -d '{"user": {"email": "xx@xxxx", "password": "xxx", "enabled": true, "name": "admin", "tenantId": null}}'
INFO:urllib3.connectionpool:Starting new HTTP connection (1): 8080
Unable to establish connection to http://cinnamon:35357/v2.0/users

Turns out the curl is trying to reach out through the :8080 port which is my proxy for external connections. So I set proxy to blank on the shell and it worked.

# export http_proxy=

However, this gives rise to 2 bugs that I am thinking of filing.

Bug 1: the python-keystoneclient does not show the "--debug" option on the command line when its run with "--help". This is a problem since this would have cut short by debgugging time by almost a day. I had to figure this out by going through the sources, not particularly efficient.

Bug 2: Handling the presence of the http_proxy varibale inside the python-keystoneclient. Maybe this is a bug that needs to be pushed to curl rather than python-keystoneclient.

Update: Filed bug 1 https://bugs.launchpad.net/python-keystoneclient/+bug/1328813 (https://bugs.launchpad.net/python-key...)

Update: Filed bug 2 https://bugs.launchpad.net/python-keystoneclient/+bug/1328837 (https://bugs.launchpad.net/python-key...)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-11 00:39:45 -0500

Seen: 693 times

Last updated: Jun 11 '14