Ask Your Question
1

ERROR: openstackclient.shell Exception raised: six>=1.6.0

asked 2014-06-10 06:03:58 -0500

bhaskar gravatar image

updated 2014-06-10 06:50:53 -0500

while Installing devstack these error came

13:20:46 ERROR: openstackclient.shell Exception raised: six>=1.6.0 13:20:46 + ADMIN_TENANT= 13:20:46 ++ openstack user create admin --project '' --email <email address="" hidden=""> --password 3de4922d8b6ac5a1aad9 13:20:46 ++ grep ' id ' 13:20:46 ++ get_field 2 13:20:46 ++ read data 13:20:47 ERROR: openstackclient.shell Exception raised: six>=1.6.0 13:20:47 + ADMIN_USER= 13:20:47 ++ openstack role create admin 13:20:47 ++ grep ' id ' 13:20:47 ++ get_field 2 13:20:47 ++ read data 13:20:47 ERROR: openstackclient.shell Exception raised: six>=1.6.0 13:20:47 + ADMIN_ROLE= 13:20:47 + openstack role add --project --user 13:20:47 ERROR: openstackclient.shell Exception raised: six>=1.6.0 13:20:47 + exit_trap 13:20:47 + local r=1 13:20:47 ++ jobs -p 13:20:47 + jobs= 13:20:47 + [[ -n '' ]] 13:20:47 + kill_spinner 13:20:47 + '[' '!' -z '' ']' 13:20:47 + exit 1

Thanks

edit retag flag offensive close merge delete

Comments

edit question and add more details, logs and what needs to be solved.

SGPJ gravatar imageSGPJ ( 2014-06-10 06:13:29 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2014-06-11 01:39:44 -0500

SGPJ gravatar image

updated 2014-06-11 01:41:09 -0500

link

Here is a bit more details about the issue:

Previously, in devstack, pip was installed by downloading a specific version (1.4.1) from a tarball from pypi. Since devstack 7b63c5e [1], pip is now installed with get-pip.py. Until recently, the version installed by get-pip.py was 1.4.1.

At about the same time, get-pip.py has been updated [2] to install pip 1.5.6 instead.

Beginning with pip 1.5.1, you don't need to have setuptools installed prior to pip installation. If setuptools is not found, it will be installed for you, otherwise it won't. Note that no particular setuptools version is required. [3]

How does it relate to the six package? Well, it looks like the six package is installed from wheel. (which uses the .dist-info directory)

Support for .dist-info directories (used by wheel packages) was added in setuptools 0.6.28. Ubuntu Precise 12.04 provides setuptools 0.6.24 [4] which is too old for our needs.

Although pip now bundles setuptools (since 1.5.1) [3], other packages are still using the system version of setuptools to discover installed packages. For six to be found by other packages, we need to install/update setuptools >= 0.6.28.

This is why we need to update setuptools to the latest to provide us the needed version to make six discoverable again.

[1] https://github.com/openstack-dev/devs... [2] https://github.com/pypa/pip/commit/2b... [3] http://pip.readthedocs.org/en/latest/... [4] http://packages.ubuntu.com/precise/py...

edit flag offensive delete link more

Comments

Thanks. Same problem here. Did you try with any other versions of ubuntu? (13.x or 14.x)

Guido García gravatar imageGuido García ( 2014-06-11 12:57:54 -0500 )edit
0

answered 2014-06-10 10:17:34 -0500

I believe that you are hitting this bug: https://bugs.launchpad.net/python-openstackclient/+bug/1326811 (https://bugs.launchpad.net/python-ope...) It looks like the fix was merged around 23:00 UTC June 9th

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-10 06:03:58 -0500

Seen: 1,048 times

Last updated: Jun 11 '14