Ask Your Question
0

Ceph installation in ubuntu

asked 2014-06-10 01:16:57 -0500

Wayn3 gravatar image

I am trying to install ceph and deploy a ceph cluster on my local machine

This is my ceph.conf file http://paste.openstack.org/show/83475/

When i run "sudo mkcephfs -a -c /etc/ceph/ceph.conf -k ceph.keyring" this is what i get.

temp dir is /tmp/mkcephfs.jsgS1CaXsX
preparing monmap in /tmp/mkcephfs.jsgS1CaXsX/monmap
/usr/bin/monmaptool --create --clobber --add a 192.168.122.1:6789 --print /tmp/mkcephfs.jsgS1CaXsX/monmap
/usr/bin/monmaptool: monmap file /tmp/mkcephfs.jsgS1CaXsX/monmap
/usr/bin/monmaptool: generated fsid c7d55008-7aa8-45ba-b12f-eb33e289bf1d
epoch 0
fsid c7d55008-7aa8-45ba-b12f-eb33e289bf1d
last_changed 2014-06-10 11:41:29.035464
created 2014-06-10 11:41:29.035464
0: 192.168.122.1:6789/0 mon.a
/usr/bin/monmaptool: writing epoch 0 to /tmp/mkcephfs.jsgS1CaXsX/monmap (1 monitors)

WARNING: mkcephfs is now deprecated in favour of ceph-deploy. Please see: 
 http://github.com/ceph/ceph-deploy
=== osd.0 === 
2014-06-10 11:41:29.775845 b723d740 -1 journal FileJournal::_open: disabling aio for non-block journal.  Use journal_force_aio to force use of aio anyway
2014-06-10 11:41:31.171910 b723d740 -1 journal FileJournal::_open: disabling aio for non-block journal.  Use journal_force_aio to force use of aio anyway
2014-06-10 11:41:31.191248 b723d740 -1 filestore(/var/lib/ceph/osd/ceph-0) could not find 23c2fcde/osd_superblock/0//-1 in index: (2) No such file or directory
2014-06-10 11:41:31.899676 b723d740 -1 created object store /var/lib/ceph/osd/ceph-0 journal /var/lib/ceph/osd/ceph-0/journal for osd.0 fsid c7d55008-7aa8-45ba-b12f-eb33e289bf1d
2014-06-10 11:41:31.899908 b723d740 -1 auth: error reading file: /var/lib/ceph/osd/ceph-0/keyring: can't open /var/lib/ceph/osd/ceph-0/keyring: (2) No such file or directory
2014-06-10 11:41:31.900173 b723d740 -1 created new key in keyring /var/lib/ceph/osd/ceph-0/keyring

WARNING: mkcephfs is now deprecated in favour of ceph-deploy. Please see: 
 http://github.com/ceph/ceph-deploy
=== osd.1 === 
2014-06-10 11:41:32.735817 b7275740 -1 journal FileJournal::_open: disabling aio for non-block journal.  Use journal_force_aio to force use of aio anyway
2014-06-10 11:41:34.021265 b7275740 -1 journal FileJournal::_open: disabling aio for non-block journal.  Use journal_force_aio to force use of aio anyway
2014-06-10 11:41:34.029724 b7275740 -1 filestore(/var/lib/ceph/osd/ceph-1) could not find 23c2fcde/osd_superblock/0//-1 in index: (2) No such file or directory
2014-06-10 11:41:34.841417 b7275740 -1 created object store /var/lib/ceph/osd/ceph-1 journal /var/lib/ceph/osd/ceph-1/journal for osd.1 fsid c7d55008-7aa8-45ba-b12f-eb33e289bf1d
2014-06-10 11:41:34.841507 b7275740 -1 auth: error reading file: /var/lib/ceph/osd/ceph-1/keyring: can't open /var/lib/ceph/osd/ceph-1/keyring: (2) No such file or directory
2014-06-10 11:41:34.841693 b7275740 -1 created new key in keyring /var/lib/ceph/osd/ceph-1/keyring

WARNING: mkcephfs is now deprecated in favour of ceph-deploy. Please see: 
 http://github.com/ceph/ceph-deploy
=== mds.a === 
creating private key for mds.a keyring /var/lib/ceph/mds/ceph-a/keyring
creating /var ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-06-11 07:52:06 -0500

Wayn3 gravatar image

I managed to run both the osd's using ceph-osd i.e. to start osd.0 i used

ceph-osd -i 0 -c /etc/ceph/ceph.conf

and for os 1 i replaced the 0 in the above command with 1

edit flag offensive delete link more

Comments

note that -c /etc/ceph/ceph.conf is optional since it is the default

dachary gravatar imagedachary ( 2014-07-05 06:51:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-10 01:16:57 -0500

Seen: 1,232 times

Last updated: Jun 11 '14