Ask Your Question
0

Devstack installation fails with a message:ERROR: openstackclient.shell Exception raised: requests>=1.1

asked 2014-06-06 07:01:20 -0600

Vinodh gravatar image

updated 2014-08-25 06:18:20 -0600

When i tried to install ICEHOUSE , i got struck up with this error.

last few lines of ./stack.sh
Waiting for keystone to start...
+ timeout 60 sh -c 'while ! curl --noproxy '\''*'\'' -k -s http://127.0.0.1:5000/v2.0/ >/dev/nu
+ is_service_enabled tls-proxy
++ set +o
++ grep xtrace
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ SERVICE_ENDPOINT=http://127.0.0.1:35357/v2.0
+ is_service_enabled tls-proxy
++ set +o
++ grep xtrace
+ local 'xtrace=set -o xtrace'
+ set +o xtrace
+ return 1
+ export OS_TOKEN=akil
+ OS_TOKEN=akil
+ export OS_URL=http://127.0.0.1:35357/v2.0
+ OS_URL=http://127.0.0.1:35357/v2.0
+ create_keystone_accounts
++ openstack project create admin
++ get_field 2
++ read data
++ grep ' id '
ERROR: openstackclient.shell Exception raised: requests>=1.1
+ ADMIN_TENANT=
++ openstack user create admin --project '' --email admin@example.com --password supersecret
++ grep ' id '
++ get_field 2
++ read data
ERROR: openstackclient.shell Exception raised: requests>=1.1
+ ADMIN_USER=
++ openstack role create admin
++ grep ' id '
++ get_field 2
++ read data
ERROR: openstackclient.shell Exception raised: requests>=1.1
+ ADMIN_ROLE=
+ openstack role add --project --user
ERROR: openstackclient.shell Exception raised: requests>=1.1
+ exit_trap
+ local r=1
++ jobs -p
+ jobs=
+ [[ -n '' ]]
+ kill_spinner
+ '[' '!' -z '' ']'
+ exit 1
edit retag flag offensive close merge delete

Comments

Edit the question and add more details please. This is not enough for anyone to give you any useful suggestion.

smaffulli gravatar imagesmaffulli ( 2014-06-06 16:40:05 -0600 )edit

Please provide more info. Provide the last 20 lines of the stack.sh's output

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-06-09 06:40:49 -0600 )edit

I am also having same problem.How to resolve by you?? Thank you

jagan gravatar imagejagan ( 2014-06-10 08:33:32 -0600 )edit

jagan, Please try the answer below and then ask further question.

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-06-10 23:56:54 -0600 )edit

I am able to resolve it.. Not sure about the exact solution as I tried many ways.. Mostly due to Permission issue.

Vinodh gravatar imageVinodh ( 2014-07-22 04:28:27 -0600 )edit

2 answers

Sort by » oldest newest most voted
2

answered 2014-06-21 00:10:56 -0600

subha gravatar image

Please use the stable version of Devstack.

edit flag offensive delete link more
4

answered 2014-06-09 23:46:18 -0600

Kashyap Kopparam gravatar image

updated 2014-11-24 03:14:11 -0600

You can try to upgrade the requests package using pip and then run stack.sh again.

$ pip install --upgrade requests setuptools

$ ./stack.sh

edit flag offensive delete link more

Comments

I tried it,but unable to overcome the problem

jagan gravatar imagejagan ( 2014-06-11 08:38:31 -0600 )edit
1

yes, I am also facing the same issue.

rgaut gravatar imagergaut ( 2014-06-11 14:50:29 -0600 )edit

Please post the output of $ pip show requests

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-06-12 07:08:56 -0600 )edit

Hello ,

I m seeing the same error . After executing the following command. pip show requests

The message on the terminal is as following.

 Name: requests 
 Version: 2.3.0
 Location: /usr/local/lib/python2.7/dist-packages 
 Requires:
amanchhabra gravatar imageamanchhabra ( 2014-06-20 16:44:48 -0600 )edit
1

Try this $ pip install --upgrade setuptools

its working for me.

rgaut gravatar imagergaut ( 2014-06-30 10:39:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-06-06 07:01:20 -0600

Seen: 1,416 times

Last updated: Nov 24 '14