Ask Your Question
0

cinder.volume.manager driver is uninitialized [closed]

asked 2014-06-05 16:40:22 -0500

danoreilly gravatar image

When I attempt to create a volume the status is always "error". When i look in the cinder log file, I get many:
2014-06-05 15:38:24.285 33872 INFO cinder.volume.manager [-] Updating volume status
2014-06-05 15:38:24.286 33872 WARNING cinder.volume.manager [-] Unable to update stats, LVMISCSIDriver -2.0.0 driver is uninitialized.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by danoreilly
close date 2014-06-09 14:17:19.340930

Comments

Does the volume group in your cinder configuration match the volume group that was setup on the server:

volume_group = {vg name}

Run vgdisplay, see if it matches.

mpetason gravatar imagempetason ( 2014-06-09 10:24:56 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-09 08:32:58 -0500

esv gravatar image

updated 2014-06-09 08:33:52 -0500

I ran into this problem last night, I am running RHEL 6.5 and Openstack Havana (I tried Icehouse and it was a nightmare) and solved in the most bizarre way by making the following modifications to my /etc/sudoers file.

################ Defaults    requiretty
cinder    ALL=(ALL) NOPASSWD: ALL

once these changes are saved, I restarted openstack-cinder-volume service, right after that I was able to create a volume without any problems.

service openstack-cinder-volume restart
edit flag offensive delete link more

Comments

On CentOS 6.5, we experienced the same error. The (roughly the same) sudoers line above was provided by an /etc/sudoers.d/cinder file, so we didn't need to add that. Instead, we had not created the LVM volume group specified the /etc/cinder/cinder.conf. Created and restarted the service, working.

mrballcb gravatar imagemrballcb ( 2014-06-13 07:48:34 -0500 )edit

Hi , did you solve this by changing the cinder user in Controller node or on the storage node where cinder-volume is running ?

vgdub gravatar imagevgdub ( 2018-09-02 12:59:06 -0500 )edit
0

answered 2014-06-05 21:06:16 -0500

dbaxps gravatar image
Set in  cinder.conf file :-
volume_clear = none
edit flag offensive delete link more

Comments

That didn't change anything.

danoreilly gravatar imagedanoreilly ( 2014-06-06 08:50:00 -0500 )edit

Did you restart cinder services after change ?

dbaxps gravatar imagedbaxps ( 2014-06-06 08:57:40 -0500 )edit

yes i did.

danoreilly gravatar imagedanoreilly ( 2014-06-06 09:02:20 -0500 )edit

I am having the same problem. and I tried the abovr changes in sudoers and cinder.con and restarted cinder-volume but nothing

Bilel gravatar imageBilel ( 2015-09-05 14:31:33 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-06-05 16:40:22 -0500

Seen: 8,385 times

Last updated: Jun 09 '14