Ask Your Question
1

Glance API not working [closed]

asked 2014-06-04 12:06:52 -0600

venkystays gravatar image

updated 2014-06-06 17:31:41 -0600

smaffulli gravatar image

Hi,

I am using RDO packstack (all-in-one deployment) .... I have a strange issue. Horizon works ( i am able to log in and use the dashboard ). glance command line tools work

Glance image-list is listing all the images ...

Glance image-show is listing all the details of the images ...

Glance image-download is downloading the images .....

Glance image-create is also working

But if use the REST API equivalent of the above mentioned commands ... i am not getting response for any of the APIs. Identity service is installed properly ( identity API also works ... i am able to fetch tokens when i make a POST API call from a remote machine)

But when i use the token and request for the list of images ... i get the following response

 This seems to be like an error connecting to http://192.168.99.95:9292/v1/images. The response status was 0.
 Check out the W3C XMLHttpRequest Level 2 spec for more details about when this happens.

I used glance-control to restart the api and the registry ... and the services were restarted successfully. But the issue is still not resolved for me .. What could be wrong ?

packstack is installed on centos 6.5

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-17 07:42:07.976448

Comments

When you say 'glance command line tools work' - you mean that the 'glance index' shows the image list?

Itzik gravatar imageItzik ( 2014-06-04 16:43:52 -0600 )edit

f that still doesn't give you the answers you need, you should specify exactly how you are are making these requests to the API.

rbowen gravatar imagerbowen ( 2014-06-06 14:54:01 -0600 )edit

I am invoking the POST API from a google chrome browser using POSTMAN REST Client .. I am invoking this API request from a remote machine. All REST API calls to identity service works. But none of the REST API calls work for glance (both glance and identity service are running on the same machine

venkystays gravatar imagevenkystays ( 2014-06-11 04:04:43 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-05 08:24:02 -0600

larsks gravatar image

The glance command line tool does use the REST API. In fact, if you run it with --debug it will show you exactly what requests it is making. You can use this to compare the working requests with the requests you're making that are not working correctly.

edit flag offensive delete link more
0

answered 2014-06-11 07:43:54 -0600

venkystays gravatar image

Hi,

The issue was not with glance.  When i issued glance -d image-list  i could see that the glance API was getting called (using CURL) and it was working.  Then i checked the iptables and turned out to be an issue with the firewall rules.

Packstack --all-in-one creates entries in the iptable , for all openstack APIs except glance. I could not see an entry for port 9292 . Hence any remote REST API call to glance was failing

I included an entry to iptables to accept all inbound traffic on port 9292. Then the issue got resolved.

Now i am able to send rest API request to glance (from remote servers).

Thanks for all the help in resolving the issue.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-04 12:06:52 -0600

Seen: 775 times

Last updated: Jun 11 '14