How to not require admin to join ext network?

asked 2014-06-04 09:01:30 -0500

don gravatar image

updated 2014-06-04 09:19:30 -0500

A recent change ( https://review.openstack.org/#/c/85189/ ) means I now must have admin rights in order to join an external network. Formerly I did not. This is breaking my config.

My config is such that I have one public 'ext' network, which is NAT to the world (since i don't have public IPv4 to allocate as floating IP). I want my users to be able to create instances and have them join this public network.

Does anybody have a solution? making everyone an admin is not what I have in mind.

weirdly, if i run 'nova boot...' i don't need to be admin. But if i use horizon 'create instance from image' i get a 'forbidden' message as per the above link.

$ neutron net-show public
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | cd9d266a-dbe7-4145-a373-30bfb16a65d9 |
| name                      | public                               |
| provider:network_type     | flat                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 16920310-2fa0-4585-85a0-449de34965e9 |
| tenant_id                 | admin                                |
+---------------------------+--------------------------------------+

is setup similar to the guide ( http://docs.openstack.org/trunk/insta... ) but with flat physical instead.

edit retag flag offensive close merge delete