Ask Your Question
0

how to troubleshoot instance generating status error

asked 2014-06-04 08:08:35 -0500

JayG gravatar image

I have installed icehouse openstack on ubuntu 14.04 server. I have create 3 seperate nodes. one for controller running keystone, image service, nova controller service and neutron controller service with dashboard service. Second for compute and third for network node.

I have done all the possible troubleshooting with the help of already available online help and blogs and checked all the available logs, but not getting any clue.

Whenever I create a instance its status always reflects as ERROR.

I am trying to create instance from command line and dashboard but facing same issue. kindly help.

all the nodes are able to communicate with each other with ip and hostname.

controller has one management interface while compute node and network node has additional interface for instance tunnel which are accessible from both the nodes.

kindly help to troubleshoot the issue.

edit retag flag offensive close merge delete

Comments

Post /var/log/nova/nova-compute.log from Compute Node ( for IceHouse) and /var/log/nova/compute.log on Compute Node (for Havana).

dbaxps gravatar imagedbaxps ( 2014-06-04 10:35:15 -0500 )edit

I don't hav this log file on my compute node, i can see only nova-manage.log on my compute node

JayG gravatar imageJayG ( 2014-06-05 03:04:02 -0500 )edit

OK. Can you find anywhere on your system /var/log/nova/*compute.log

dbaxps gravatar imagedbaxps ( 2014-06-05 03:58:41 -0500 )edit

but still i am not getting its console

JayG gravatar imageJayG ( 2014-06-05 06:12:03 -0500 )edit

while accessing through url it is showing loading only.

JayG gravatar imageJayG ( 2014-06-05 06:17:16 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-06-05 06:01:13 -0500

JayG gravatar image

thanks a lot, because of your clue i found the error. I found the log file under /var/log/upstart/nova-compute.log

the error was with the code which was typo mistake in vncserver_proxyclient_address I have corrected it and now the instance is starting and getting the ip also

edit flag offensive delete link more
0

answered 2018-11-18 16:11:14 -0500

SP gravatar image

In my new install, i do not see /var/log/nova folder itself is not created and my search from root for nova-compute.log itself is missing. I am trying to find the reason for my dashboard-->Launch instance failure reason. Is there any way to check whether my installation for openstack went well and i am not missing any files ?

Thanks Shan

Instance Console Unable to load console. Please reload page to try again.

edit flag offensive delete link more

Comments

Write a new question instead of an answer to a four-years-old question.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-19 01:31:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-06-04 08:08:35 -0500

Seen: 6,069 times

Last updated: Nov 18 '18