Ask Your Question

OpenStack REST API output missing real IPs [closed]

asked 2014-06-04 04:48:19 -0500

Jaikiran Pai gravatar image

Hello everyone,

I'm new to OpenStack and have been reading the documentation and testing some of the REST APIs that are exposed. I have been able to get the basics working and have been able to invoke the APIs from a REST client.

One such API I'm trying is fetching endpoints for a particular tenant as noted here ( with a GET request for http://IP:5000/v2.0/tokens/myvalidtoken/endpoints (http://IP:5000/v2.0/tokens/myvalidtok...) with the X-Auth-Token header set to my valid token. The JSON output it generates is as follows (just the relevant parts):

 "name": "nova",
 "adminURL": "http://controller:8774/v2/fef6a56cb3ec4adca49d769b604ae572",
 "internalURL": "http://controller:8774/v2/fef6a56cb3ec4adca49d769b604ae572",
 "publicURL": "http://controller:8774/v2/fef6a56cb3ec4adca49d769b604ae572",
 "type": "compute",

Why do the URLs have "controller" in there instead of an IP?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-06-04 16:53:08.176725

1 answer

Sort by ยป oldest newest most voted

answered 2014-06-04 08:15:39 -0500

SamYaple gravatar image

They are there because you created the endpoint with that address. Most of the guides use "controller" as the hostname. You may have copied and pasted the endpoint creation. You can delete that endpoint and create a new nova endpoint with the appropriate hostname.

edit flag offensive delete link more


Thank you Sam. I'll get in touch with the admin who set this up for us.

Jaikiran Pai gravatar imageJaikiran Pai ( 2014-06-04 08:18:01 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2014-06-04 04:48:19 -0500

Seen: 153 times

Last updated: Jun 04 '14