Ask Your Question
1

Unable to load the virtualization driver: No module named vmwareapi [closed]

asked 2013-07-15 23:12:41 -0500

anonymous user

Anonymous

updated 2013-07-16 05:04:05 -0500

Hi

i use folsom release. i have a vm (10.102.10.3) as controller node and a vm (10.101.1.85)as nova-compute node . I put vmware SDK in webapp of tomcat but when i restart nova-compute it get error:

( furthermore , after using libvirt successfully for testing ESXi I change nova.conf file and comment every lines about libvirt and add lines for supporting vmware. Is it true????) in other word for change senario of libivirt to vmwareapi what changes should be removed?

2013-07-07 08:55:37 2509 INFO nova.compute.manager [-] Loading compute driver 'v mwareapi.VMwareESXDriver'
2013-07-07 08:55:37 2509 ERROR nova.compute.manager [-] Unable to load the virtu alization driver: No module named vmwareapi

when curl http://10.101.1.85:8080/vmware/SDK/wsdl/vim25/vimService.wsdl, output is :

<?xml version="1.0" encoding="UTF-8" ?>
<!--
   Copyright 2005-2010 VMware, Inc. All rights reserved.
-->
<definitions targetNamespace="urn:vim25Service"
   xmlns="http://schemas.xmlsoap.org/wsdl/"
   xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
   xmlns:interface="urn:vim25"
>
   <import location="vim.wsdl" namespace="urn:vim25" />
   <service name="VimService">
      <port binding="interface:VimBinding" name="VimPort">
         <soap:address location="https://localhost/sdk/vimService" />
      </port>
   </service>
</definitions>
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 08:39:58.652679

4 answers

Sort by ยป oldest newest most voted
2

answered 2013-09-18 03:52:54 -0500

JuanLucas gravatar image

updated 2013-09-18 03:53:34 -0500

Be aware that the module name is vmwareapi.VMWareESXDriver with a capital W and not as said in the docs with a lowercase w.

edit flag offensive delete link more

Comments

For 'Havana' you should use lowercase w

laboshinl gravatar imagelaboshinl ( 2013-11-06 06:02:57 -0500 )edit
1

answered 2013-07-21 21:33:27 -0500

Yaguang gravatar image

updated 2013-09-23 17:47:23 -0500

smaffulli gravatar image

the vmware specific documentation is for the latest trunk version of openstack. not suitable for folsom version any more, I strongly suggest you use Grizzly stable version which fix some important bugs.

edit flag offensive delete link more
0

answered 2013-09-24 17:11:44 -0500

whatson gravatar image

updated 2014-01-27 17:53:26 -0500

smaffulli gravatar image

I had the same problem and solved it. The Error ERROR nova.compute.manager [-] Unable to load the virtualization driver: No module named vmwareapi occured because I had the Folsom (2012.2) release of OpenStack installed. Different to you I didn't want to use the VMwareESXDriver, instead I wanted to try VMwareVCDriver. The required openstack release to use this driver should be at least Grizzly (2013.1). So it won't work with previous releases. Therefore I think you will have to upgrade to a newer one. I hope this answer helps.

edit flag offensive delete link more
0

answered 2013-07-16 17:26:43 -0500

armando-migliaccio gravatar image

You might be missing a package dependency for vmwareapi. Pasting more information would be useful to understand what's going on.

edit flag offensive delete link more

Comments

hi thanks,what package dependency may i missed? i used this guide http://docs.openstack.org/folsom/basic-install/content/basic-install_intro.html for installation. what info do you need? i want to know what changes is needed for change libvirt compute driver to vmwareapi driver? I used this guide http://docs.openstack.org/trunk/openstack-compute/admin/content/vmware.html for vmware hypervisor .I used openstack installation guide: http://docs.openstack.org/folsom/basic-install/content/ Please help to me

sorina gravatar imagesorina ( 2013-07-20 01:04:25 -0500 )edit
1

you have to install python-suds

ader1990 gravatar imageader1990 ( 2013-10-31 18:43:34 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-15 23:12:41 -0500

Seen: 2,459 times

Last updated: Jan 27 '14