Unable to login into the instance machine

asked 2013-07-15 12:12:01 -0500

nishtha gravatar image

updated 2013-07-17 12:31:58 -0500

I am facing problem in the log of the booted image. I booted 3 instances, all they took 3 different ips through dhcp. But only 1 is having ssh login and the cirros instance log is showing the message "169.254.169.254- network unreachable". I can ping or SSH the first instance but unable to login. It is the ubuntu image and I don't know the login username and password. The other two are not pinged or neither I can do SSH, although they have been alloted an ip by dhcp. I am not getting why it is happening so. Kindly reply

edit retag flag offensive close merge delete

Comments

I suggest you to search this site more carefully and, if you still can't find an answer, update the question with more details, log messages, configs and anything useful to debug

smaffulli gravatar imagesmaffulli ( 2013-07-15 15:57:51 -0500 )edit

Thanks smaffulli for replying, as you said I have updated my question..I am still facing the same problem. Kindly let me know about the logs and messages I should provide to solve the error

nishtha gravatar imagenishtha ( 2013-07-19 01:40:48 -0500 )edit

were you able to find solution of the issue?

koolhead17 gravatar imagekoolhead17 ( 2013-08-12 17:12:43 -0500 )edit

hi koolhead17! No my problem is yet not solved.

nishtha gravatar imagenishtha ( 2013-08-13 15:10:24 -0500 )edit

So we had the same issue, can you bundle a image without cloud-init & try starting it? It should work. This happens because your instance is not getting connected to the metadata server.

koolhead17 gravatar imagekoolhead17 ( 2013-08-14 01:19:14 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-26 11:06:23 -0500

Qiming gravatar image

prebuilt ubuntu images most likely has cloud-init installed. The username could be ec-user or ubuntu, based on the version you are using. Often times, you are not allowed to log in using 'root' account. You are supposed to log in using a key-pair.

If you cannot ssh or ping to your instance, you may want to check whether security group has been set up properly.

Without further configuration details, there could be other reasons.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-15 12:12:01 -0500

Seen: 219 times

Last updated: Apr 26 '14