Ask Your Question
1

nova-compute fails to connect to nova-conductor

asked 2014-05-30 11:02:37 -0600

updated 2014-05-30 13:24:56 -0600

Hi. I've been following the OpenStack Installation Guide for Red Hat Enterprise Linux, CentOS, and Fedora ( http://docs.openstack.org/trunk/install-guide/install/yum/content/ (http://docs.openstack.org/trunk/insta...) ) to make a 3-node deployment (i.e., controller, network and compute) of OpenStack Icehouse in CentOS 6.4.

All services are installed in their respective nodes and appear to be functioning. However, the service nova-compute in the compute node fails to connect to the service nova-conductor in the controller node (though both services are effectively connected to the message server, qpid , running in the controller node).

The following is a snippet of /var/log/nova/compute.log after restarting the service nova-compute in the compute node:

2014-05-30 11:55:01.746 20946 INFO nova.openstack.common.periodic_task [-] Skipping periodic task _periodic_update_dns because its interval is negative
2014-05-30 11:55:01.856 20946 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver'
2014-05-30 11:55:01.906 20946 INFO oslo.messaging._drivers.impl_qpid [-] Connected to AMQP server on controller:5672
2014-05-30 11:55:01.932 20946 INFO oslo.messaging._drivers.impl_qpid [-] Connected to AMQP server on controller:5672
2014-05-30 11:55:11.953 20946 WARNING nova.conductor.api [req-7acb5bd3-f2ae-4f0f-996a-0da5e51279b3 None None] Timed out waiting for nova-conductor. Is it running? Or did this service start before nova-conductor?

Any assistance (or suggestion) would be appreciated. I can provide any additional information that would help troubleshoot the issue.

Thanks.

UPDATE:

  • I'm running CentOS 6.4 in all three nodes.
  • I'm trying to deploy OpenStack Icehouse.
edit retag flag offensive close merge delete

Comments

Can you try restarting qpidd and the conductor services and if it helps?

Itzik ( 2014-05-30 11:09:44 -0600 )edit

Tried that several times to no effect. I've just did again and nova-compute still fails to connect to nova-conductor. Thanks for the suggestion, though.

gkeller2 ( 2014-05-30 11:23:23 -0600 )edit

Which release of Openstack (Havana or IceHouse) you attempt to setup ( 3 Node Config) on RH's system ( which one RHEL 6.5, CentOS 6.5, Fedora 20) ?

dbaxps ( 2014-05-30 12:58:27 -0600 )edit

CentOS 6.4. Sorry for not clarifying that before. I'll edit the question.

gkeller2 ( 2014-05-30 13:10:07 -0600 )edit

Which release of Openstack (Havana or IceHouse) you attempt to setup ?

dbaxps ( 2014-05-30 13:20:19 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-06-06 12:17:38 -0600

updated 2014-06-06 12:18:24 -0600

Following the suggestion from dbaxps, I replaced qpid with rabbitMQ. This allowed for the service nova compute running in the compute node to connect to the service nova conductor in the controller node.

I'm still unclear why qpid was failing and probably I won't ever find out. From now on, I'll probably use rabbitMQ in future deployments.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-05-30 11:02:37 -0600

Seen: 1,076 times

Last updated: Jun 06 '14