Ask Your Question
0

OpenStack IceHouse Neutron with existing external network

asked 2014-05-29 12:28:00 -0500

anonymous user

Anonymous

updated 2014-06-18 15:32:03 -0500

rbowen gravatar image

So I have followed the following set of instructions for my vms. http://openstack.redhat.com/Neutron_with_existing_external_network

When I bring up a VM it comes up with a Address in the pool for allocations, but I can't ping out or reach it from my existing network. This is the last piece for me to figure out and then I can go full on testing before deployment.

[root@openstack2 ~(keystone_admin)]# neutron subnet-create --name public_subnet --enable_dhcp=False --allocation-pool=start=172.16.230.10,end=172.16.242.200 --gateway=172.16.1.2 public 172.16.0.0/16

I ran that per the documentation to match my physical network that I have already in place with physical routers, firewalls, switches etc.

when I look at neutron for the information I get this

(neutron) net-list
+--------------------------------------+---------+----------------------------------------------------+
| id                                   | name    | subnets                                            |
+--------------------------------------+---------+----------------------------------------------------+
| 606f6ea3-787c-4f68-af81-e6db8dc12a0e | private | 84e95850-c359-4fa1-8ed8-f20d0e3f5e9f 10.0.0.0/24   |
| 81022d03-8188-4c0a-ba2c-52b6ba7a31bd | public  | 91625f03-e55c-4b87-8c08-845a9dda88fe 172.16.0.0/16 |
+--------------------------------------+---------+----------------------------------------------------+
(neutron) subnet-list
+--------------------------------------+----------------+---------------+-----------------------------------------------------+
| id                                   | name           | cidr          | allocation_pools                                    |
+--------------------------------------+----------------+---------------+-----------------------------------------------------+
| 84e95850-c359-4fa1-8ed8-f20d0e3f5e9f | private_subnet | 10.0.0.0/24   | {"start": "10.0.0.2", "end": "10.0.0.254"}          |
| 91625f03-e55c-4b87-8c08-845a9dda88fe | public_subnet  | 172.16.0.0/16 | {"start": "172.16.230.10", "end": "172.16.242.200"} |
+--------------------------------------+----------------+---------------+-----------------------------------------------------+
(neutron) router-list
+--------------------------------------+--------------+-----------------------------------------------------------------------------+
| id                                   | name         | external_gateway_info                                                       |
+--------------------------------------+--------------+-----------------------------------------------------------------------------+
| 4029f412-51c9-4ced-807b-f9fdbc46112e | admin-public | {"network_id": "81022d03-8188-4c0a-ba2c-52b6ba7a31bd", "enable_snat": true} |
| a6979924-1676-44a8-8eec-fdccb73244a5 | router1      | {"network_id": "81022d03-8188-4c0a-ba2c-52b6ba7a31bd", "enable_snat": true} |
+--------------------------------------+--------------+-----------------------------------------------------------------------------+
(neutron) port-list
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 033adf06-bcfd-4206-9738-3a4450282816 |      | fa:16:3e:b4:67:3d | {"subnet_id": "84e95850-c359-4fa1-8ed8-f20d0e3f5e9f", "ip_address": "10.0.0.3"}      |
| 7dc799dc-60e0-4202-b27e-4c5ad2530a68 |      | fa:16:3e:fa:35:d9 | {"subnet_id": "91625f03-e55c-4b87-8c08-845a9dda88fe", "ip_address": "172.16.230.15"} |
| a1757648-b851-4a40-bd0d-e6558518a900 |      | fa:16:3e:24:ea:39 | {"subnet_id": "84e95850-c359-4fa1-8ed8-f20d0e3f5e9f", "ip_address": "10.0.0.2"}      |
| b2b48681-db24-4f5f-b250-b97725976d38 |      | fa:16:3e:9a:39:41 | {"subnet_id": "91625f03-e55c-4b87-8c08-845a9dda88fe", "ip_address": "172.16.230.11"} |
| bf6a1dbe-741d-4b2f-a8f8-095d8e99fb25 |      | fa:16:3e:d9:3f:41 | {"subnet_id": "84e95850-c359-4fa1-8ed8-f20d0e3f5e9f", "ip_address": "10.0.0.1"}      |
| f9ac3b86-c7e5-4f49-b1ff-1328ec4e0da6 |      | fa:16:3e:a5:b5:38 | {"subnet_id": "91625f03-e55c-4b87-8c08-845a9dda88fe", "ip_address": "172.16.230.10"} |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+

I can't ping the vm from the host machine either which is odd to me and makes me think theres a routing issue.

edit retag flag offensive close merge delete

Comments

Can you ping from the VM to external host ( e.g. 8.8.8.8 )?

Itzik gravatar imageItzik ( 2014-05-29 15:01:25 -0500 )edit

No I can't ping the vm from the host or out from the vm.

moos3 gravatar imagemoos3 ( 2014-05-29 15:48:09 -0500 )edit

Do you have L3 agent running on the Network Node? Do you have access to an external network from the Network Node?

Itzik gravatar imageItzik ( 2014-05-29 23:51:48 -0500 )edit

Its a All in one node. So everything is running on the one node. Also I have network access on the physical box itself just not to the vm's or from the vms.

moos3 gravatar imagemoos3 ( 2014-06-02 08:26:02 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-06-20 15:07:26 -0500

rbowen gravatar image

At this point, I'd recommend that you take your question to #rdo on Freenode, where people can help you get to the root of the problem. There's probably some small detail that someone there can help you tease out that we're still missing.

edit flag offensive delete link more
0

answered 2014-06-23 01:52:09 -0500

I had faced a similar issue. My problem was solved when I matched the subnet with the external network subnet. I would suggest trying to use 172.16.0.0/24 instead of 172.16.0.0/16 for the public network.

According to the suggestion at http://openstack.redhat.com/forum/discussion/526/understanding-and-configuring-quantum-floating-ip/p1 (http://openstack.redhat.com/forum/dis...) , "Your floating IP network should be defined with the same mask even if you are starting and ending the pool as a subset".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-05-29 12:28:00 -0500

Seen: 672 times

Last updated: Jun 23 '14