Ask Your Question
0

"Error: Service key is not running" in multi-node Devstack installation

asked 2014-05-29 10:35:16 -0500

Amir gravatar image

Hi,

I am new to Openstack, and I am trying to install a two-node Devstack using two virtual machines instances. The controller installation seems to work fine, but when I install the compute node, the installation fails at 'Error: Service key is not running'. Details are provided below.

I spent all day on this, help would be very gratefully appreciated :)

Thanks! Amir

Following is my local.conf for the controller node:

# Sample ``local.conf`` for user-configurable variables in ``stack.sh``

# NOTE: Copy this file to the root ``devstack`` directory for it to
# work properly.

# ``local.conf`` is a user-maintained setings file that is sourced from ``stackrc``.
# This gives it the ability to override any variables set in ``stackrc``.
# Also, most of the settings in ``stack.sh`` are written to only be set if no
# value has already been set; this lets ``local.conf`` effectively override the
# default values.

# This is a collection of some of the settings we have found to be useful
# in our DevStack development environments. Additional settings are described
# in http://devstack.org/local.conf.html
# These should be considered as samples and are unsupported DevStack code.

# The ``localrc`` section replaces the old ``localrc`` configuration file.
# Note that if ``localrc`` is present it will be used in favor of this section.

# Minimal Contents
# ----------------

# While ``stack.sh`` is happy to run without ``localrc``, devlife is better when
# there are a few minimal variables set:

# If the ``*_PASSWORD`` variables are not set here you will be prompted to enter
# values for them by ``stack.sh`` and they will be added to ``local.conf``.
[[local|localrc]]
ADMIN_PASSWORD=1q2w3e4r
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50
MULTI_HOST=1
FIXED_NETWORK_SIZE=4096
#FIXED_RANGE=172.31.1.0/24
#FLOATING_RANGE=192.168.20.0/25
#HOST_IP=10.3.4.5

# ``HOST_IP`` should be set manually for best results if the NIC configuration
# of the host is unusual, i.e. ``eth1`` has the default route but ``eth0`` is the
# public interface.  It is auto-detected in ``stack.sh`` but often is indeterminate
# on later runs due to the IP moving from an Ethernet interface to a bridge on
# the host. Setting it here also makes it available for ``openrc`` to include
# when setting ``OS_AUTH_URL``.
# ``HOST_IP`` is not set by default.
#HOST_IP=w.x.y.z


# Logging
# -------

# By default ``stack.sh`` output only goes to the terminal where it runs.  It can
# be configured to additionally log to a file by setting ``LOGFILE`` to the full
# path of the destination log file.  A timestamp will be appended to the given name.
LOGFILE=$DEST/logs/stack.sh.log

# Old log files are automatically removed after 7 days to keep things neat.  Change
# the number of days by setting ``LOGDAYS``.
LOGDAYS=2

# Nova logs will be colorized if ``SYSLOG`` is not set; turn this off by setting
# ``LOG_COLOR`` false.
#LOG_COLOR=False


# Using milestone-proposed branches
# ---------------------------------

# Uncomment these to grab the milestone-proposed branches from the repos:
#CINDER_BRANCH=milestone-proposed
#GLANCE_BRANCH=milestone-proposed
#HORIZON_BRANCH=milestone-proposed
#KEYSTONE_BRANCH=milestone-proposed
#KEYSTONECLIENT_BRANCH=milestone-proposed
#NOVA_BRANCH=milestone-proposed
#NOVACLIENT_BRANCH=milestone-proposed ...
(more)
edit retag flag offensive close merge delete

Comments

Hi, Can you try running the compute node with enable_service n-cpu instead of the one you have?

Itzik gravatar imageItzik ( 2014-05-29 14:41:44 -0500 )edit

Thanks, I tried but no change. Perhaps I am configuring the compute node wrong. Perhaps "key" is not required at the compute node, because its services are provided by the controller, and I should somehow configure the installation to reflect this?

Amir gravatar imageAmir ( 2014-06-01 04:34:21 -0500 )edit

As far as I can tell you only need n-cpu and q-agt. You do this by enable_service n-cpu q-agt. Run ./unstack.sh before running ./stack.sh again

Itzik gravatar imageItzik ( 2014-06-01 08:35:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-02 02:47:10 -0500

Amir gravatar image

Thanks Itzik, this indeed solved the problem :-) I didn't use the particular services you suggested, but removing most of the services did the trick. I will probably need to restore some of them later, but this is great for the time being.

edit flag offensive delete link more

Comments

What is your final list of services? Please reedit the Answer so others can benefit if they have similar issue.

Itzik gravatar imageItzik ( 2014-06-02 14:25:11 -0500 )edit

Hey Amir, can you please let me know how u resolved the error "service Key ...."error.

Hi Itzik, is q-agt is required to enable for the compute node if I am using ml2 pluging and the driver is openDayLight.

sarojsingi gravatar imagesarojsingi ( 2014-09-24 05:38:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-29 10:35:16 -0500

Seen: 522 times

Last updated: Jun 02 '14