Ask Your Question
0

devstack - 'No route to host' after reboot

asked 2014-05-29 05:55:23 -0500

snowch gravatar image

I have installed openstack inside a virtualbox guest.

After running stack.sh and initiating some instances, I'm able to ssh into my instances ok.

However, after rebooting the guest and running rejoin-stack.sh, openstack seems to start ok, but I can no longer access my instances:

vagrant@puppet:~$ nova list
+-------------+---------------+--------+-------------+--------------------+
| ID          | Name          | Status | Power State | Networks           |
+-------------+---------------+--------+-------------+--------------------+
| cf3298da... | php111php-ad  | ACTIVE | Running     | private=10.11.12.2 |
| 1d8832d5... | php111php-d81 | ACTIVE | Running     | private=10.11.12.3 | 
+-------------+---------------+--------+-------------+--------------------+

vagrant@puppet:~$ ssh -i openstack-demo-keypair.pem root@10.11.12.2
ssh: connect to host 10.11.12.2 port 22: No route to host

The network seems to be the same before and after the reboot. Here is some debug information:

vagrant@puppet:~$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.0.2.2        0.0.0.0         UG        0 0          0 eth0
10.0.2.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.0.3.0        0.0.0.0         255.255.255.0   U         0 0          0 lxcbr0
10.11.12.0      0.0.0.0         255.255.255.0   U         0 0          0 br100
172.17.0.0      0.0.0.0         255.255.0.0     U         0 0          0 docker0
192.168.56.0    0.0.0.0         255.255.255.0   U         0 0          0 eth1
192.168.92.0    0.0.0.0         255.255.255.0   U         0 0          0 br100


vagrant@puppet:~$ ifconfig
br100     Link encap:Ethernet  HWaddr 08:00:27:59:04:7c
          inet addr:10.11.12.1  Bcast:10.11.12.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe59:47c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9266 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:761693 (761.6 KB)  TX bytes:1692 (1.6 KB)

docker0   Link encap:Ethernet  HWaddr fe:1b:45:d8:65:00
          inet addr:172.17.42.1  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::7858:6eff:fef5:1376/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1152 (1.1 KB)  TX bytes:398 (398.0 B)

eth0      Link encap:Ethernet  HWaddr 08:00:27:ea:90:19
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:feea:9019/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23944 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12306684 (12.3 MB)  TX bytes ...
(more)
edit retag flag offensive close merge delete

Comments

Just run:-
$ . keystonerc_admin
$ openstack-status

dbaxps gravatar imagedbaxps ( 2014-05-29 06:52:55 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-05-29 06:53:15 -0500

SGPJ gravatar image

I think it is stuck and you may need to unstack then run stack.sh. This is problem with Devstack. Else you can switch to better one packstack (RDO).

edit flag offensive delete link more
0

answered 2014-05-29 20:19:37 -0500

I have the same issue. Neither running rejoin-stack nor stack.sh again works. The problem is that the interfaces aren't being set up properly.

Before ./stack.sh

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:1a:6b:36:87:ac brd ff:ff:ff:ff:ff:ff
    inet 192.0.2.150/24 brd 192.0.2.255 scope global eth0
    valid_lft forever preferred_lft forever
    inet6 fe80::21a:6bff:fe36:87ac/64 scope link
    valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:1b:77:40:fb:22 brd ff:ff:ff:ff:ff:ff

after shack.sh

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet 169.254.169.254/32 scope link lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UP group default qlen 1000
    link/ether 00:1a:6b:36:87:ac brd ff:ff:ff:ff:ff:ff
    inet6 fe80::21a:6bff:fe36:87ac/64 scope link
    valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:1b:77:40:fb:22 brd ff:ff:ff:ff:ff:ff
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 4a:32:c2:fc:be:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
    valid_lft forever preferred_lft forever
5: br100: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:1a:6b:36:87:ac brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global br100
    valid_lft forever preferred_lft forever
    inet 192.0.2.150/24 brd 192.0.2.255 scope global br100
    valid_lft forever preferred_lft forever
    inet6 fe80::68de:beff:fe51:f452/64 scope link
    valid_lft forever preferred_lft forever
7: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UNKNOWN group default qlen 500
    link/ether fe:16:3e:25:95:a4 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc16:3eff:fe25:95a4/64 scope link
    valid_lft forever preferred_lft forever

after rebooting and rerunning stack.sh, the interfaces look likt they did originally. Not positive ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-29 05:55:23 -0500

Seen: 1,138 times

Last updated: May 30 '14