Ask Your Question
0

cloud-init doesn't work in progress

asked 2014-05-28 21:30:26 -0600

Jaesang Lee gravatar image

updated 2014-05-28 21:31:37 -0600

Hi stackers,

I use Ubuntu Coud Image(https://cloud-images.ubuntu.com/releases/14.04/release/ubuntu-14.04-server-cloudimg-arm64-disk1.img).

But when i'm boot ubuntu vm, It doesn't work in progress after cloud-init. I think some network setting is missed, How can I correct this situation?

This is last log about console.log of VM.

  • Starting configure network device [ OK ]

  • Stopping cold plug devices [ OK ]

  • Stopping log initial device creation [ OK ]

Cloud-init v. 0.7.5 running 'init-local' at Thu, 29 May 2014 02:15:53 +0000. Up 5.53 seconds.

  • Starting enable remaining boot-time encrypted block devices [ OK ]

Cloud-init v. 0.7.5 running 'init' at Thu, 29 May 2014 02:15:53 +0000. Up 5.99 seconds.

ci-info: ++++++++++++++++++++++++++Net device info++++++++++++++++++++++++++

ci-info: +--------+------+-------------+---------------+-------------------+

ci-info: | Device | Up | Address | Mask | Hw-Address |

ci-info: +--------+------+-------------+---------------+-------------------+

ci-info: | lo | True | 127.0.0.1 | 255.0.0.0 | . |

ci-info: | eth0 | True | 10.110.1.24 | 255.255.255.0 | fa:16:3e:62:93:a4 |

ci-info: +--------+------+-------------+---------------+-------------------+

ci-info: +++++++++++++++++++++++++++++++Route info++++++++++++++++++++++++++++++++

ci-info: +-------+-------------+-------------+---------------+-----------+-------+

ci-info: | Route | Destination | Gateway | Genmask | Interface | Flags |

ci-info: +-------+-------------+-------------+---------------+-----------+-------+

ci-info: | 0 | 0.0.0.0 | 10.110.1.15 | 0.0.0.0 | eth0 | UG |

ci-info: | 1 | 10.110.1.0 | 0.0.0.0 | 255.255.255.0 | eth0 | U |

ci-info: +-------+-------------+-------------+---------------+-----------+-------+

edit retag flag offensive close merge delete

Comments

can we know how do you implement openstack. do you use neutron for networking? or just nova-network?

senyapsudah gravatar imagesenyapsudah ( 2014-05-29 00:15:38 -0600 )edit

I use nova-network.

I solved a problem, It because nova-api-metadata doesn't work. After running nova-api-metadata, It works in progress well.

Jaesang Lee gravatar imageJaesang Lee ( 2014-05-29 00:26:22 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-05-29 00:26:41 -0600

Jaesang Lee gravatar image

I solved a problem, It because nova-api-metadata doesn't work. After running nova-api-metadata, It works in progress well.

edit flag offensive delete link more

Comments

I'm having the same issue. Were you able to query 169.254.169.254? How did you enable nova-api-metadata?

marcantonio gravatar imagemarcantonio ( 2014-06-09 09:24:57 -0600 )edit
0

answered 2014-07-01 01:42:05 -0600

jmppok gravatar image

I'm having the samilar issue. I hava upload the ubuntu-14.04-server-cloudimg-arm64-disk1.img by "glance" and start an instance by "nova boot". Then the "nova list" shows the instance is running.

+--------------------------------------+----------------+--------+------------+-------------+----------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+----------------+--------+------------+-------------+----------------------+ | 920472d5-d26a-4ea5-b86d-777091fdabff | demo-instance1 | ACTIVE | - | Running | demo-net=203.0.113.2 | +--------------------------------------+----------------+--------+------------+-------------+----------------------+

But when I see the console.log, it was null.

And I can not access the instance of 203.0.113.2 by ping, ssh or virsh.

So, would you like to help me to know how can I start an instance of ubuntu-14.04-server-cloudimg-arm64-disk1.img?

Thanks very much.

Bert Lee

ligh4@lenovo.com

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-28 21:30:26 -0600

Seen: 989 times

Last updated: Jul 01 '14