Ask Your Question
0

[keystone] The resource could not be found. (HTTP 404)

asked 2014-05-28 08:10:05 -0500

anonymous user

Anonymous

i try to add user to keystone like that $keystone user-create --name=keystone --pass=keystone --email=keystone

but i got this error Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL]

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-28 08:49:05 -0500

m7med gravatar image

updated 2014-05-28 08:49:51 -0500

Thanks Marcantonio for you help, i did this

[@mail ~]$ echo $OS_AUTH_URL 
http://localhost:35357/v2.0 
[@mail ~]$ sudo keystone user-create --name=admin --pass=admin --email=admin@localhost 
Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL]

and the error still exist! any suggestion ?

edit flag offensive delete link more

Comments

Don't use sudo.

marcantonio gravatar imagemarcantonio ( 2014-05-28 09:00:33 -0500 )edit
0

answered 2014-05-28 08:21:12 -0500

marcantonio gravatar image

You can either export an environment variable first:

export OS_AUTH_URL=http://controller_host:35357/v2.0

or just pass it as an argument to keystone:

$ keystone --os-auth-url http://controller_host:35357/v2.0 user-create etc...

Assuming that keystone is running on controller_host, that is.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-05-28 08:10:05 -0500

Seen: 3,272 times

Last updated: May 28 '14