Ask Your Question
0

Connection to neutron failed: [Errno 111] Connection refused [closed]

asked 2014-05-27 11:29:53 -0500

anonymous user

Anonymous

I installed Openstack from the OpenStack Installation Guide for Ubuntu 12.04/14.04 (LTS) - icehouse but when I started creating the external network: neutron net-create ext-net --shared --router:external=True I got the error: Connection to neutron failed: [Errno 111] Connection refused

I sourced the file: source admin-openrc.sh

I checked the previous quiries about this issue and tried the solutions but did not work for me. I ensured that in my config files, the rabbit_host=my_controller

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by naa
close date 2014-06-08 05:38:17.117826

Comments

Please, reproduce

   [root@icehouse1 ~(keystone_admin)]# service neutron-server status
    Redirecting to /bin/systemctl status  neutron-server.service
    neutron-server.service - OpenStack Neutron Server
       Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled)
       Active: active (running) since Tue 2014-05-27 13:36:54 MSK; 8h ago
     Main PID: 1163 (neutron-server)
       CGroup: /system.slice/neutron-server.service
               └─1163 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neu...

    May 27 13:36:54 icehouse1.localdomain systemd[1]: Started OpenStack Neutron Server.
    [root@icehouse1 ~(keystone_admin)]# iptables-save | grep neutron_server
    -A INPUT -s 192.168.1.127/32 -p tcp -m multiport --dports 9696 -m comment --comment "001 neutron server incoming neutron_server_192.168.1.127_192.168.1.127" -j ACCEPT
    -A INPUT -s 192.168.1.137/32 -p tcp -m multiport --dports 9696 -m comment --comment "001 neutron server incoming neutron_server_192.168.1.127_192.168.1.137" -j ACCEPT
    [root@icehouse1 ~(keystone_admin)]# netstat -lnpt | grep 9696
    tcp        0 ...
(more)
dbaxps gravatar imagedbaxps ( 2014-05-27 12:47:40 -0500 )edit

I am getting this result when executing the command: sudo service neutron-server status neutron-server stop/waiting

and the following command gives no output: iptables-save | grep neutron_server

naa gravatar imagenaa ( 2014-05-28 05:05:59 -0500 )edit

What says /var/log/neutron/server.log ?

dbaxps gravatar imagedbaxps ( 2014-05-28 05:13:16 -0500 )edit

The log file has nothing in it.. Does that mean that neutron server isn't running? If so, how do I start it? Cause basic command to start the neutron server has already been executed. sudo service neutron-server start neutron-server start/running, process 32485

naa gravatar imagenaa ( 2014-05-28 05:21:34 -0500 )edit

Check $service neutron-server status
start/running
and get back to reports I asked to reproduce:-
$ iptables-save | grep neutron_server
$ netstat -anpt | grep 9696

dbaxps gravatar imagedbaxps ( 2014-05-28 05:30:24 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2014-05-28 05:53:20 -0500

naa gravatar image

It got solved, the reason is that the /etc/neutron/neutron.conf has extra spaces ! The network was created when I removed the spaces.

edit flag offensive delete link more

Comments

what do you mean by extra spaces? can you explain it..i am facing same problem!

hpetwal gravatar imagehpetwal ( 2015-04-19 03:35:45 -0500 )edit

actually .. the problem is with space before and after =. rather than XXX = XXX it should be XXX=XXX.

Hope it helps.

Vikram gravatar imageVikram ( 2015-06-09 21:04:28 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-05-27 11:29:53 -0500

Seen: 4,718 times

Last updated: May 28 '14