Ask Your Question
1

IOError: [Errno 13] Permission denied: '/tmp/.secret_key_store

asked 2014-05-27 05:49:53 -0500

sdimber gravatar image

I am getting the following errors when trying to login to dashboard

[Tue May 27 16:07:54 2014] [error] [client ] mod = importlib.import_module(self.SETTINGS_MODULE) [Tue May 27 16:07:54 2014] [error] [client ] File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module [Tue May 27 16:07:54 2014] [error] [client ] __import__(name) [Tue May 27 16:07:54 2014] [error] [client ] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 222, in <module> [Tue May 27 16:07:54 2014] [error] [client ] from local.local_settings import * # noqa [Tue May 27 16:07:54 2014] [error] [client ] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 93, in <module> [Tue May 27 16:07:54 2014] [error] [client ] SECRET_KEY = secret_key.generate_or_read_from_file(os.path.join(LOCAL_PATH, '.secret_key_store')) [Tue May 27 16:07:54 2014] [error] [client ] File "/usr/lib/python2.6/site-packages/horizon/utils/secret_key.py", line 65, in generate_or_read_from_file [Tue May 27 16:07:54 2014] [error] [client ] with open(key_file, 'r') as f: [Tue May 27 16:07:54 2014] [error] [client ] IOError: [Errno 13] Permission denied: '/tmp/.secret_key_store' ^C

I am using the following version of django.[root@controller Packages]# rpm -qa | grep python-django python-django-compressor-1.3-2.el6.noarch python-django-openstack-auth-1.1.5-1.el6.noarch python-django-horizon-2014.1-1.el6.noarch python-django-appconf-0.5-3.el6.noarch

[root@controller Packages]# openstack-status | grep dashboard openstack-dashboard: 500

edit retag flag offensive close merge delete

Comments

https://bugzilla.redhat.com/show_bug....
Would run : yum update python-django-*

dbaxps gravatar imagedbaxps ( 2014-05-27 06:26:40 -0500 )edit

[root@controller ~]# yum update python-django-* Loaded plugins: product-id, refresh-packagekit, security, subscription-manager This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. Setting up Update Process No Packages marked for Update

i have the lastest package look like the bug is reintroduced

sdimber gravatar imagesdimber ( 2014-05-27 06:56:26 -0500 )edit

Your problem is This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. It's RHEL 6.5 . As legal customer you can register system for RH Subscription Management and then choose required channel. Another option switch to CentOS 6.5 and get it with no trouble with Subscriptions.

dbaxps gravatar imagedbaxps ( 2014-05-27 07:41:52 -0500 )edit

Take a look at my last comment to thread https://ask.openstack.org/en/question...

dbaxps gravatar imagedbaxps ( 2014-05-28 05:16:38 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-27 07:48:38 -0500

dbaxps gravatar image

updated 2014-05-27 07:49:24 -0500

Your problem is - This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. It's RHEL 6.5 . As legal customer you can register system for RH Subscription Management and then choose required channel. You also have to know which channel to select. 
Another option switch to CentOS 6.5. Enable EPEL (just in case) and get it with no trouble with Subscriptions.
edit flag offensive delete link more

Comments

I registered and have update the said package but that does not solve my problem

sdimber gravatar imagesdimber ( 2014-05-28 04:59:37 -0500 )edit
0

answered 2014-06-24 05:36:01 -0500

sdimber gravatar image

The problem was with some configuration in localsettings file. I reinstalled the dashboard and configured new localsetting file. It works like charmm

edit flag offensive delete link more

Comments

If your OS is RHEL 6.5 , have you been following http://openstack.redhat.com/Quickstart

dbaxps gravatar imagedbaxps ( 2014-06-24 06:16:30 -0500 )edit
0

answered 2016-04-13 16:07:12 -0500

yshcherbak gravatar image

i have set SECRET_KEY='SECRET_STRING' in /etc/openstack-dashboard/local_settings and the error gone

edit flag offensive delete link more
0

answered 2016-09-06 12:18:02 -0500

Fishbone gravatar image

If you followed the documentation from the Openstack official website ensure that you copy the proper directives from the original conf file. Notable, The documentation mentions to use the www-data or apache user to setup https on the server. Your configured user may be different than the user that is authorized for the file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-27 05:49:53 -0500

Seen: 2,673 times

Last updated: Sep 06 '16